Closed Bug 412593 Opened 15 years ago Closed 15 years ago

Double clicking on mail in list opens body in browser

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mozilla, Unassigned)

Details

(Keywords: regression)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008011601 SeaMonkey/2.0a1pre

I'm running with the message pane normally switched off. When double clicking on a mail in the list (mainly double click on the subject) it should open a new window (or re-use the existing one) and open the header and the body in there. Now I see that instead of doing that the body is opened in the browser instead. Not for all but for some messages.

This seems to be something that regressed recently, probably within the last two days. The SeaMonkey build I'm using on Linux now (2008011601) has the problem, the one that I was using before (2008011402) didn't have it. I also see this on OS/2, but there my last build was a bit older.
Can you tie that to a specific (kind of) mail?
It was definitely more than one message where this happened. But I think it only happened for IMAP.
I have tried to reproduce this with the current Windows Build 2008011602 and an IMAP-Account, but the Messages were all opend in a new MailNews-Window like expected, none in an Browser-Window. 

End of Oktober i have got an closed-to-issue when an News-Posting was opend in the Browser, see <5ormqjFo7dgeU1@mid.individual.net> in d.c.s.m.nb with link to screenshot, but I was not able to reproduce this. 
I have now found a way to reproduce this, as follows:

- double click on one email in the main mail window
- it opens in its own window
- switch back to the main mail window
- press delete to remove the message that we just opened
  (I do that often because if I do that from the message window
  it will automatically go to the next one which I don't always
  like)
- now double click on an _unread_ message in the same folder
- this seems to temporarily be opened by the existing mail window
  in the background before it is "transferred" to the browser window

I think the change from previous nightlies is that for those the message window was closed when the message was deleted in the main window. Don't see anything in the regression window that would fit, though...
I'm now running Gecko/2008012901 on OS/2 and when deleting a message from the message list the window closes again, so this is now WFM. Will resolve soon unless it reappears.
I do see this every now and then on Linux but haven't seen this on OS/2 again.
I have not seen this any more over the last few days. I think that bug 413200 was related somehow and that was checked in 11 days ago. Maybe it was really fixed by that, in any case it is WFM.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.