Wrong display of importance icons

VERIFIED FIXED in 0.8

Status

defect
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: omarb.public, Assigned: Fallen)

Tracking

({regression})

Details

Attachments

(3 attachments)

Reporter

Description

12 years ago
Previously when I set importance flag to 'High' or 'Normal' I saw three or two different size icons in the bottom of New Event dialog. And now I can see only one icon.

Works with 2008011103 build. 
Fails with 2008011406 build.
Flags: blocking-calendar0.8?
Reporter

Comment 1

12 years ago
Posted image Previous display
Reporter

Comment 2

12 years ago
Posted image Current display
Both set with high priority
IMO this bug is INVALID. What is the purpose of showing all three icons ins the dialog?

But before I mark the bug as INVALID, I'd like to get Christian's feedback here. Christian, can you please comment on this issue here.
Flags: blocking-calendar0.8? → blocking-calendar0.8-
I can confirm as regression. In Sunbird 0.7 the status bar displayed the text "Importance: " + one/two/three boxes dependent on low/medium/high priority. Now it doesn't display the text anymore and always shows one box independent on the priority. --> It's not clear anymore what the box icon indicates. And it's not possible to distinguish between the different priorities anymore.

Regression range:
Works in Sunbird 0.8pre (2008-01-10-05)
Fails in Sunbird 0.8pre (2008-01-11-05)
Checkins during regression range: http://tinyurl.com/33lofh
Caused by the checkin for Bug 379029.
Philipp, can you please elaborate on why you changed the code this way in bug 379029?
Posted patch Fix v1Splinter Review
Sorry about that, more than one icon should of course be shown.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #299721 - Flags: review?(Berend.Cornelius)
OS: Windows XP → All
Hardware: PC → All
Version: Mozilla 1.8 Branch → unspecified

Comment 7

12 years ago
Comment on attachment 299721 [details] [diff] [review]
Fix v1

Talked with Christian about the patch because I object that we are using different symbols for the priority. In the treeview and the coming toolbarbutton we are using "!" for high priority and not the bars like in the statusbar of the calendar-event dialog. Christian and also me found that we should align this.
Berend, I changed my mind. I think we should fix the bug as it stands and then take care of changing icons some other time. I'd give that a lower priority than this bug though. I'm not quite happy with using the arrows in the event dialog.

Comment 9

12 years ago
Comment on attachment 299721 [details] [diff] [review]
Fix v1

patch works as advertised; As discussed with Christian we talk over the symbol question in a later step.r=berend.
Attachment #299721 - Flags: review?(Berend.Cornelius) → review+

Comment 10

12 years ago
issue is fixed
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
berend, until now I didnt check in this patch since I was waiting for your review. Therefore the issue wasnt fixed until now:

Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Target Milestone: --- → 0.8

Comment 12

12 years ago
Checked in latest nightly build 2008013018 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
Flags: blocking-calendar0.8-
You need to log in before you can comment on or make changes to this bug.