Spellcheck incorrectly flags properly spelled words and not misspelled ones

RESOLVED FIXED

Status

()

Core
Spelling checker
--
trivial
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Ian Carman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 479334], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Spellcheck highlights the word "locator" (correct spelling) but not the word "locater" (incorrect spelling. Downloaded and installed Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11, no joy. Same failure has been duplicated with words such as: lector, donator, idolator, elicitor, pronator, advocator, Pictor, Validator, and others (all of these are the correct dictionary spelling!)

Reproducible: Always

Steps to Reproduce:
1. Downloaded and installed latest Firefox browser (see above).
2. pulled the entire list of English words that rhymes with "locator" from multiple online dictionaries and from within the Mozilla home page and entered them as text
3. Doublechecked same words against MS Word spellcheck, Internet Explorer spellcheck, Open Office spellcheck. Failure only occurs in Mozilla.
Actual Results:  
Very same result. Correct words are flagged by spell check, misspelled words are ignored.

Expected Results:  
Spellcheck should highlight the MISspelled words and ignore CORRECTLY spelled words.

Comment 1

10 years ago
locator and locater are both valid words; however locater is the less common spelling, at least in American English. 

http://www.merriam-webster.com/dictionary/locater

Comment 2

9 years ago
Partial dupe of bug 460344, plus a few more words.
Status: UNCONFIRMED → NEW
Component: General → Spelling checker
Depends on: 479334
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → spelling-checker

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 479334]
You need to log in before you can comment on or make changes to this bug.