Closed Bug 412746 Opened 12 years ago Closed 12 years ago

Email addresses defect after event->task conversion on Mac

Categories

(Calendar :: Lightning Only, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: Fallen)

References

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- create an event and invite some people
- convert this event into a task
- check the eMail addresses of the attendees

RESULT:
=======

- the eMail addresses are defect
- RSVP=TRUE;CN=Berend Cornelius;PARTSTAT=NEEDS-ACTION;

EXPECTED RESULT:
================

- the eMail addresses should be correct

REPRODUCIBLE:
=============

- always
Flags: blocking-calendar0.8+
This might be the same problem as bug 408652. Working on a fix to find out.
I checked this issue with lightning build 2008020420 ( bug 408652 is fixed now) but this bug is not fixed. But now there are no eMail addresses visible.
Now this bug seems to be duplicate to bug 411884. 
Assignee: nobody → Berend.Cornelius
Duplicate of this bug: 411884
The problem is that somewhere in the drag process, newlines are being incorrectly converted. This is the case for both clipboard and drag service, but there is a different outcome.

In the clipboard, all \r\n are converted to \n on mac.
In the drag service, all \r\n are converted to \n\n on mac.

While the first case is silently ignored and parsed correctly, the second results in errors with multi-line ical components.

The attached patch takes care by replacing \n\n with \r\n when recieving the calendar data. This is not the best solution since its probably a shortcoming of nsDragDrop.js/nsTransferable.js, but given the short time to 0.8 this is all I can do. Also, the files mentioned are not part of calendar.
Assignee: Berend.Cornelius → philipp
Status: NEW → ASSIGNED
Attachment #304051 - Flags: review?(Berend.Cornelius)
Version: Trunk → unspecified
Comment on attachment 304051 [details] [diff] [review]
[checked in] Fix conversion

patch looks good;r=berend
Attachment #304051 - Flags: review?(Berend.Cornelius) → review+
Comment on attachment 304051 [details] [diff] [review]
[checked in] Fix conversion

While this does fix an issue with email addresses, it doesn't seem to fix all of it. On a different mac (with the same system!!) we were able to reproduce the initial issue. 

Leaving bug open, first patch checked in.
Attachment #304051 - Attachment description: Fix conversion → [checked in] Fix conversion
berend, can you take a look at this at work? I won't have access to a mac until the weekend.
I once again tested the bug on two diffent machines and could not verify the problem anymore. Yesterday I tested on Christian's machine and found out today that I started thunderbird with a wrong profile -> my fault. So I can now clearly say the bug has been fixed
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
@Berend: Thanks for further investigation.

I checked this issue with the latest nightly build 2008021921 on Mac and this issue and also bug 411884 are fixed -> Task is fixed and verified.
Status: RESOLVED → VERIFIED
Target Milestone: --- → 0.8
You need to log in before you can comment on or make changes to this bug.