Closed Bug 412811 Opened 12 years ago Closed 12 years ago

xpconnect-tools build broken

Categories

(Core :: XPConnect, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9beta3

People

(Reporter: armin76, Assigned: armin76)

References

Details

Attachments

(1 file)

Webservices build broke with the checkin of bug 411327. 
nsIXPCNativeCallContext shouldn't be used anymore.  This patch will fix it.
Version: unspecified → Trunk
Assignee: general → nobody
Component: JavaScript Engine → XPConnect
QA Contact: general → xpconnect
Assignee: nobody → armin76
Attachment #297574 - Flags: superreview?(dbradley)
Attachment #297574 - Flags: review?(dbradley)
Attachment #297574 - Flags: superreview?(dbradley) → superreview?(mrbkap)
Attachment #297574 - Flags: superreview?(mrbkap)
Attachment #297574 - Flags: superreview+
Attachment #297574 - Flags: review?(dbradley)
Attachment #297574 - Flags: review+
Comment on attachment 297574 [details] [diff] [review]
js_xpconnect_fix.patch

Fix build failure caused by bug 411327.
Attachment #297574 - Flags: approval1.9?
Status: NEW → ASSIGNED
Comment on attachment 297574 [details] [diff] [review]
js_xpconnect_fix.patch

<bsmedberg> reed: it's NPODB, doesn't need approval
Attachment #297574 - Flags: approval1.9?
Checking in js/src/xpconnect/sample/xpcsample1.cpp;
/cvsroot/mozilla/js/src/xpconnect/sample/xpcsample1.cpp,v  <--  xpcsample1.cpp
new revision: 1.13; previous revision: 1.12
done
Checking in js/src/xpconnect/tools/src/nsXPCToolsCompiler.cpp;
/cvsroot/mozilla/js/src/xpconnect/tools/src/nsXPCToolsCompiler.cpp,v  <--  nsXPCToolsCompiler.cpp
new revision: 1.15; previous revision: 1.14
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11
You need to log in before you can comment on or make changes to this bug.