Bookmarks Toolbar and Unfiled Bookmarks can be moved(copied) to the bookmarks menu, but then can't be deleted

RESOLVED DUPLICATE of bug 406089

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 406089
11 years ago
9 years ago

People

(Reporter: Danial Horton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

The Bookmarks Toolbar and Unfiled Bookmarks can be 'duplicated' to the bookmarks menu, but then cannot be removed without deleting the 'Places' files from the Firefox Profile.

Dragging the duplicate out of the booksmark menu does not reintegrate it with the original item.

Reproducible: Always

Steps to Reproduce:
1. Drag Bookmarks toolbar or Unfiled Bookbarks to the bookmarks menu to create a duplicate
2. Try to delete the duplicate.
Actual Results:  
Creates an unremoval folder item which is linked to the bookmark toolbar or unfiled bookmark menu.

Expected Results:  
These items should be removal from the bookmarks menu without having to delete the 'places' files.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011723 Minefield/3.0b3pre

This problem sounds like bug 406089.
(Reporter)

Comment 2

11 years ago
yes, i believe they are exactly the same, i didn't see that when i searched for the term 'duplicate + bookmarks toolbar'

i never thought that anyone would want to drag and drop the Bookmarks menu itself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406089

Comment 3

11 years ago
Typo fix in Summary, s/Unified/Unfiled
Summary: Bookmarks Toolbar and Unified Bookmarks can be moved(copied) to the bookmarks menu, but then can't be deleted → Bookmarks Toolbar and Unfiled Bookmarks can be moved(copied) to the bookmarks menu, but then can't be deleted
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.