Closed Bug 412918 Opened 13 years ago Closed 13 years ago

New Tasks run out of the view

Categories

(Calendar :: Calendar Views, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: chris.j.bugzilla, Assigned: berend.cornelius09)

Details

Attachments

(1 file, 1 obsolete file)

Steps to reproduce:

In Today Pane, or Task Mode:
     - Add tasks to the task list until the scrollbar occurs
     - Add some more ...

Bug: The newest tasks are not displayed, because the ran out of
the visible area.

Suggestion for a fix:
Add tasks by default on top of the list.

I'm requesting blocking‑calendar0.8 for that bug, because it is bug which has very high "annoyance factor" for the daily life....
Flags: blocking-calendar0.8?
Flags: blocking-calendar0.8? → blocking-calendar0.8+
Assignee: nobody → Berend.Cornelius
I wonder If I should select the new created task. By selecting the new task we would change the visibe range of the tree and assure that the new task will always be visible - on the other hand the user might not want that.  Any comments?
It seams that the task is selected. I'm not sure, because the selection is painted gray. Please assure that the feature of adding (multiple) tasks by simply hitting return does not break.
Attached patch patch v. #1 (obsolete) — Splinter Review
I just added one line to make sure that the added item is visible. As I discuessed with Christian I kept the behaviour that the task is added to the end of the tree.
Attachment #303020 - Flags: review?
Attached patch patch v. #1Splinter Review
Attachment #303021 - Flags: review?(philipp)
Attachment #303020 - Attachment is obsolete: true
Attachment #303020 - Flags: review?
Comment on attachment 303021 [details] [diff] [review]
patch v. #1

r=philipp, please add spaces around the - operator.
Attachment #303021 - Flags: review?(philipp) → review+
patch checked in on trunk and MOZILLA_1_8_BRANCH

=> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Checked in latest nightly builds (lightning and sunbird 20080214) -> task is fixed and verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.