Readonly text field doesn't show readonly caret anymore when focused

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

(4 keywords)

Trunk
x86
Windows XP
access, regression, sec508, testcase
Points:
---
Bug Flags:
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
This was something that was added in bug 193316, but it's now broken again in current trunk builds.

This regressed between 2007-06-27 and 2007-06-28, so a regression from bug 237964.
(Reporter)

Comment 1

11 years ago
CC-ing Aaron, since he fixed this in bug 193316.

Updated

11 years ago
Flags: blocking1.9?
Keywords: access, sec508
Flags: wanted1.9+
Flags: blocking1.9?
Flags: blocking1.9-

Comment 2

11 years ago
Roc, I still think it should be blocking+ since current generation screen readers require the visible caret for the user to be able to read through the text.

Also, it's a regression.
It's not a regression from a previous release, right?

Comment 4

11 years ago
Roc. Ok. You got me there :P
We'll still take a patch but you'll have to write it.
I'm seeing a non-blinking caret in the readonly input in attachment 197875 [details] and the readonly textbox in attachment 198269 [details], so this is WFM. Anyone else still see the issue?

Comment 7

11 years ago
It's WFM now as well! I wonder what fixed it.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.