position:fixed; right:0; moves content over GFX scrollbar

VERIFIED DUPLICATE of bug 5195

Status

()

P3
normal
VERIFIED DUPLICATE of bug 5195
19 years ago
18 years ago

People

(Reporter: hjtoi-bugzilla, Assigned: pierre)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Open layout/xml/tests/toc/rights.xml. We have the blue box "toggle toc" to the 
right. Change the book.css stylesheet like below, and the box moves right 
obscuring the scrollbar.

Index: book.css
===================================================================
RCS file: /cvsroot/mozilla/layout/xml/tests/toc/book.css,v
retrieving revision 1.2
diff -u -r1.2 book.css
--- book.css	2000/05/19 05:26:10	1.2
+++ book.css	2000/06/02 08:21:09
@@ -134,7 +134,9 @@
    background-color: #CCE6F3;
    color: darkblue;
    width: 10em;
-   margin-right: 0.5em;
+   /*margin-right: 0.5em;*/
+   position: fixed;
+   right: 0;
 }
 
 navbar title {
(Assignee)

Comment 1

19 years ago
The problem only happens with GFX scrollbars. It's a dup of bug 5195. I'm going 
to attach a simpler testcase over there.


*** This bug has been marked as a duplicate of 5195 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
Summary: position:fixed; right:0; moves content over scrollbar → position:fixed; right:0; moves content over GFX scrollbar

Comment 2

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.