Closed Bug 412963 Opened 12 years ago Closed 9 years ago

[Offline] Disabled cached calendars become visible after synchronization

Categories

(Calendar :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: omarb.public, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [not needed beta][no l10n impact])

If I set a cache for remote calendar and disable the calendar it's enabled again after restart

Steps to reproduce:
1)Create a new profile
2)Subscribe to remote calendar i.e. http://www.google.com/calendar/ical/u7pke58sc91ksbm4h9pf9ofe8c%40group.calendar.google.com/public/basic.ics
3)Enable Cache
4)Restart
5)Disable the remote calendar
6)Restart

Actual result:
The remote calendar is enabled

Expected result:
The disabled calendar stays disabled after restart

Lt 2008011704
Flags: wanted-calendar0.8?
Omar, thanks for testing offline mode! Could you prefix offline bugs with something like [Offline] for easier tracking?
Summary: Disabled cached calendars are visible after restart → [Offline] Disabled cached calendars are visible after restart
Would it make sense to create a component called Offline?
Flags: wanted-calendar0.8? → wanted-calendar0.8+
I've noticed also that when remote calendars are refreshed the disabled calendars with enabled cache option become visible.
Ah yes, now I understand. I wasn't quite sure what you meant with disabled. This is a known issue. When adding events in a sync scenario, the ensureCalendarVisible() function is called.
OS: Windows XP → All
Hardware: PC → All
Summary: [Offline] Disabled cached calendars are visible after restart → [Offline] Disabled cached calendars become visible after synchronization
Version: Mozilla 1.8 Branch → unspecified
Not going to happen for 0.8.
Flags: wanted-calendar0.8+ → wanted-calendar0.8-
Works for me due to Bug 482110 using Lightning 1.0b2pre (20100428) with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5pre) Gecko/20100428 Lanikai/3.1pre.
Flags: blocking-calendar1.0+
Whiteboard: [not needed beta][no l10n impact]
Works for me using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; es-ES; rv:1.9.2.15) Gecko/20110303 Lightning/1.0b2 Thunderbird/3.1.9
Yes, it will work due to bug 482110. As soon as that bug is fixed, the original issue will return though.
This should be no problem the way bug 482110 will be fixed. Marking WFM
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Flags: blocking-calendar1.0+
You need to log in before you can comment on or make changes to this bug.