Last Comment Bug 41301 - In Editor, IFRAME is editable instead of page (editor not created)
: In Editor, IFRAME is editable instead of page (editor not created)
Status: VERIFIED DUPLICATE of bug 14156
editorbase-
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: ---
Assigned To: Kathleen Brade
: sujay
Mentors:
http://news.bbc.co.uk/
: 60869 (view as bug list)
Depends on: 34477
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-02 07:42 PDT by rubydoo123
Modified: 2003-02-27 10:16 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (200 bytes, text/html)
2000-06-04 07:44 PDT, David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
no flags Details

Description rubydoo123 2000-06-02 07:42:32 PDT
What happens is the file never completes loading in the editor. All the content 
is there, but the throbber is still spinning. This means there is no 
nsIHTMLEditor created for the document. This is probably why the NS_NO_INTERFACE 
error keeps getting thrown from nsEditorShell. After more digging, if the IFRAME 
is commented out, then the page loads and is editable.

Code snippet to use for testing:

<html>
<head><title>test</title></head>
<body>
<p>Here is an iframe:</p>
<iframe frameborder=1 width=20 height=20>IFRAME element</iframe><br>
</body>
</html>
Comment 1 Gagan 2000-06-02 13:48:52 PDT
I believe iframes are out... but I may be wrong. Nisheeth are these handled in 
the DOM? 
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2000-06-04 07:43:36 PDT
The HTML spec says (sec. 16.5):

  The information to be inserted inline is designated by the src attribute of
  this element. The contents of the IFRAME element, on the other hand, should
  only be displayed by user agents that do not support frames or are configured
  not to display frames.

IFRAMEs currently work fine, but this bug exists whether the IFRAME has a SRC
attribute or not.  However, the *contents* of the IFRAME do become editable.

Attaching a testcase.

TO REPRODUCE:
 * load attached testcase
 * Go to "File | Edit Page"

ACTUAL RESULTS:
 * The contents of the iframe are editable, the page is not.

EXPECTED RESULTS:
 * The page should be editable.  The contents of the iframe should not (?).

This seems more like an editor bug than a Layout bug.  (Note that I never saw
the throbber keep spinning.  Maybe that is fixed.)
Comment 3 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2000-06-04 07:44:01 PDT
Created attachment 9592 [details]
testcase
Comment 4 Nisheeth Ranjan 2000-06-17 19:36:59 PDT
Beth, the page loads fine now, but as David says, instead of the page becoming 
editable, the IFRAME inside the page becomes editable.  This seems like a editor 
specific issue, so re-assigning this back to you.
Comment 5 rubydoo123 2000-06-19 10:55:39 PDT
asking Simon if he has any ideas as to why the page becomes uneditable, but the 
IFRAME is editable.
Comment 6 Simon Fraser 2000-06-19 13:04:10 PDT
Yes, I do. We'll make the editor on the last IFRAME that is loaded, blowing away 
previous editors in the process. Fixing this requires some thought.

Testcase, please?
Comment 7 Simon Fraser 2000-06-19 13:14:13 PDT
Actually, I think fixing this will requires at least some of the work for 
embedding to be complete (bug 35639).
Comment 8 rubydoo123 2000-06-19 13:24:34 PDT
Simon -- tests cases are already in here, see the sample code in the file and 
David Baron attached a test case
Comment 9 rubydoo123 2000-06-23 16:30:54 PDT
setting to m18
Comment 10 Simon Fraser 2000-07-21 11:39:33 PDT
cc: valeski, dougt for embedding info. To fix this bug, I need to be able to hang 
an editor off a docShell (or equivalent), which leads us down the embedding path. 
Have you guys started down that path yet?
Comment 11 rubydoo123 2000-07-27 12:48:18 PDT
added correctness keyword and bringing it back to m19
Comment 12 rubydoo123 2000-09-19 18:24:57 PDT
moving to future per review with bij and beppe
Comment 13 Charles Manske 2000-12-11 10:28:31 PST
*** Bug 60869 has been marked as a duplicate of this bug. ***
Comment 14 Simon Fraser 2002-01-30 17:09:35 PST
Editor issue.
Comment 15 Kathleen Brade 2003-01-08 15:52:44 PST
In a recent build I now see this:
page loads fine but it not editable; clicking on links in the iframe load those
pages
Comment 16 Kathleen Brade 2003-01-09 09:51:12 PST
nsbeta1+
editorbase- for now but this is subject to change later
Comment 17 Kathleen Brade 2003-01-09 15:05:22 PST
add http://news.bbc.co.uk/ as a testcase (iframe with java)
Comment 18 Kathleen Brade 2003-02-19 12:18:29 PST
duping

*** This bug has been marked as a duplicate of 14156 ***
Comment 19 rubydoo123 2003-02-27 10:16:24 PST
verified dup

Note You need to log in before you can comment on or make changes to this bug.