"Add Bookmark" vs "Edit Bookmark"

RESOLVED DUPLICATE of bug 393509

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 393509
11 years ago
9 years ago

People

(Reporter: zwnj, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
In fx2.0 when I want to add a bookmark (pressing Ctrl+D or using "Bookmark This Page"), I had the option to press Esc, to cancel the process and get ride of that window.

Now beside that pressing Esc doesn't work, and the page will remain bookmarked, I see "Delete" button in the first time, before I set the name and/or place of the bookmark.

I think we should differ between "adding" and "editing" bookmarks; also give the user the option to cancel each process by pressing Esc.
The delete key function will be restored (see bug 393509).
Bookmarking in one click (bug 387642) is a Firefox 3 design decision and will not be changed anymore.


Component: Bookmarks → Places
QA Contact: bookmarks → places

Comment 2

11 years ago
The instant apply nature of add a bookmark in Fx3 is not going away.  However the issues about "esc" and "delete"  are being addressed in bug 393509. Please see the latest mockup in that bug for details.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393509
(In reply to comment #1)
> The delete key function will be restored (see bug 393509).
Sorry, I meant escape.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.