All calendars are deselected after Lightning update

VERIFIED FIXED in 0.8

Status

--
critical
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: sebo.moz, Assigned: dbo)

Tracking

({regression})

unspecified
regression
Bug Flags:
blocking-calendar0.8 +

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
After Lightning update all calendars are deselected. This happens when updating from a build prior to 20080106 with a build starting from Lightning 2008011604.

The same error has caused a lot of confusion when releasing 0.7. Requesting blocking status.
Flags: blocking-calendar0.8?
Flags: blocking-calendar0.8? → blocking-calendar0.8+
Works for me after updating from Sunbird/Lightning 0.7 to current 0.8pre builds.
(Reporter)

Comment 2

11 years ago
I cannot reproduce as well if I start from Lightning 0.7.
I can still reproduce with clean profile if switching from Lightning 20080105 to Lightning 20080116.
I can reproduce if upgrading from an older 0.8pre to a current 0.8pre.

However, because the error doesn't occur when upgrading from 0.7 it's not a blocker. But it should stay on the table for retest once the final 0.8 builds are available.
(Reporter)

Comment 4

11 years ago
Note to self/QA: Upgrade path from 0.5 to 0.8 should also be tested.

Comment 5

11 years ago
I did testing for 0.5 --> 0.8pre, which failed ;-(
As ssitter noted in the other bug I can't remember right now, testing 0.5 -> 0.8 will obviously fail since 0.5 -> 0.7 failed. Its the same issue. As long as 0.7 -> 0.8 is fine, I think we are good to go.

I'd still be interested whats causing this though.
(Assignee)

Comment 7

11 years ago
I can imagine a rather easy fix checking for either "calendar-main-in-composite" or "lightning-main-in-composite" in calProviderBase; taking this one.
Assignee: nobody → daniel.boelzle
(Assignee)

Comment 8

11 years ago
Created attachment 301735 [details] [diff] [review]
fix
Attachment #301735 - Flags: review?(philipp)
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → 0.8
Comment on attachment 301735 [details] [diff] [review]
fix

r=philipp
Attachment #301735 - Flags: review?(philipp) → review+
(Assignee)

Comment 10

11 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 11

11 years ago
Comment on attachment 301735 [details] [diff] [review]
fix

+        function takeOverIfNotPresent(oldPref, newPref, dontDeleteOldPref) {
...
+        takeOverIfNotPresent("lightning-main-in-composite", "calendar-main-in-composite");
+        takeOverIfNotPresent("lightning-main-default", "calendar-main-default");

Can someone explain this mysterious third parameter to me? None of the callers use it...
(Assignee)

Comment 12

11 years ago
It's a pleasure to do this: I actually recycled this function from another patch that will soon land (presumably post 0.8), i.e. for bug 412800. That patch will set up more composite calendars for today pane et al and take over the current composite props without deleting them.

Comment 13

11 years ago
(In reply to comment #10)
> Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.

Verified FIXED with Lightning 2008020719 doing an update from 0.5 release.
VERIFIED per comment#13.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.