Freeze when typing in address-bar

VERIFIED DUPLICATE of bug 414229

Status

()

--
major
VERIFIED DUPLICATE of bug 414229
11 years ago
9 years ago

People

(Reporter: linuxhippy, Unassigned)

Tracking

({hang, perf, regression})

Trunk
x86
Linux
hang, perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2

After I updated from FireFox-2.0.11 to 3.0Beta, I started typing "hotmail" into the adress-bar, but only the two letters "ho" appeard and the firefox started to consume 100% cpu.

Other adresses like "heise.de" work without problems, but "hotmail" makes the browser hang. I searched a bit on the profile and the history is realy large and contains a lot of "hotmail" entries - so maybe thats the reason why it is so slow.

Reproducible: Always

Steps to Reproduce:
1. Install my profile
2. Type "hotmail" into the location bar
3. FireFox hangs and consumes 100% CPU
Actual Results:  
it should not block

Expected Results:  
it blocks

I guess this bug is only reproduceable when you use one of my two profiles, which I will upload shortly.
(Reporter)

Comment 1

11 years ago
Bugzilla does only allow 300kb files, whereas my profiles are bzip2-compressed 8m large. Does anybody know a place where I could upload them?

Btw. the problem goes away if I call "clean private data".

lg Clemens
Component: History → Places
Keywords: hang, perf, qawanted, regression
QA Contact: history → places
Version: unspecified → Trunk
Summary: Freeze when typing in adress-bar → Freeze when typing in address-bar
(Reporter)

Comment 2

11 years ago
I uploaded the two profiles to http://uploaded.to/?id=eb3vpd
Sorry that I had to use such an ... upload site, I don't have any webspace.

I don't know how long they will be available, so best thing would be to download them and put them somewhere on a mozilla ftp server or something like that.

lg Clemens

Comment 3

11 years ago
in latest builds this problem appeared again. for me minefield freeze for 2-3 seconds after every typed or deleted letter. i.e. after every change. also it hangs about same time when scrolling results, after every pressed up/down key and after clicking on the item.

Comment 4

11 years ago
bug 414229 <-dupes?-> bug 413457
Yes, this does appear to be a dupe of bug 414229.

What's happening is: as you type into the location bar, your history is being searched for entries that match what you typed, to show in the new autocomplete drop-down (dubbed “Awesomebar” — http://mozillalinks.org/wp/2007/11/firefox-3-location-bar-just-became-almighty/ ). That's why clearing your history relieves the symptom.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414229

Updated

10 years ago
Status: RESOLVED → VERIFIED
Keywords: qawanted
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.