RTM Crash (Mac) #5: Crash at changing Character coding in this site on Mac [@ nsRenderingContextMac::SelectDrawingSurface]

VERIFIED WORKSFORME

Status

()

Core
Internationalization
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Talkback System)

Tracking

({crash, intl, topcrash})

Trunk
mozilla0.9
PowerPC
All
crash, intl, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

18 years ago
When you load this site and change character coding to Western (ISO-8859-5),
Netscape will crash or hang.

Steps of reproduce
1. Launch Netscape
2. Go to above URL by typing URL bar
3. Select View|Character coding->ISO->Western (ISO-8859-5)
Netscape will crash or hang.  

This does not happen in Win32 and Linux build.  Tested 2000-06-02-08 Mac build.

Talkback incident # 11671887

   NQD + 0x11678 (0x1fe5ce18) 
   InterfaceLib + 0x1c9b4 (0xffd14134) 
   nsRenderingContextMac::SelectDrawingSurface()  [nsRenderingContextMac.cpp, 
line 207]
   nsRenderingContextMac::Init()                                                      
[nsRenderingContextMac.cpp, line 132]
   DeviceContextImpl::InitRenderingContext()                                                             
[nsDeviceContext.cpp, line 225]
   DeviceContextImpl::CreateRenderingContext()                                                             
[nsDeviceContext.cpp, line 214]
   PresShell::CreateRenderingContext() [nsPresShell.cpp, 
line 2442]  
   PresShell::InitialReflow() [nsPresShell.cpp, line 1623]                                          
   nsXULDocument::StartLayout()  [nsXULDocument.cpp, line 4052]
   nsXULDocument::ResumeWalk() [nsXULDocument.cpp, line 5372]                                                     
   nsXULDocument::OnStopRequest()  [nsXULDocument.cpp, line 6446]
   nsDocumentOpenInfo::OnStopRequest()  [nsURILoader.cpp, line 221]
   nsCachedChromeChannel::HandleStopLoadEvent()                                                           
[nsChromeProtocolHandler.cpp, line 524]
   PL_HandleEvent() [plevent.c, line 575]                                                         
   PL_ProcessPendingEvents() [plevent.c, line 520]
   nsEventQueueImpl::ProcessPendingEvents() [nsEventQueue.cpp, line 316]
   nsMacNSPREventQueueHandler::ProcessPLEventQueue() 
[nsToolkit.cpp, line 132]
   nsMacNSPREventQueueHandler::RepeatAction() [nsToolkit.cpp, line 97]
   Repeater::DoRepeaters() [nsRepeater.cpp, line 119]
   nsMacMessagePump::DispatchEvent() [nsMacMessagePump.cpp, line 417]
   nsAppShell::DispatchNativeEvent() [nsAppShell.cpp, line 223]
   nsXULWindow::CreateNewContentWindow()  [nsXULWindow.cpp, line 1205]

Comment 1

18 years ago
cvsblame show 
 204 pierre    1.67     // quickdraw initialization
 205 beard     1.97     ::SetPort(mPort);
 206 pierre    1.56  
 207 beard     1.97     ::SetOrigin(-mGS->mOffx, -mGS->mOffy);          // line 
order...
 208 pierre    1.56  

Reassign to beard to investigate since his name show on the cvsblame.
Assignee: ftang → beard

Comment 2

18 years ago
Adding crash to keyword field.
Keywords: crash

Comment 3

18 years ago
Since this is Mac rendering related, reassigning to Don Cone.
Assignee: beard → dcone

Comment 4

18 years ago
This works for me with 6/12/2000 build.  
Tested on G4 and G3 Macs.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
I cannot reproduce this bug with 2000062608. I am going to mark this bug
verified worksforme, if you still have this problem, please repoen this bug.

Thank you for reporting a bug with mozilla(:

Zach
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
This happens in 2000-06-29-08 Mac build.  I cannot get the talkback report.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
Again.. I cannot reproduce this.. using a G4 mac os9, and g3 os8.
I tried all of the Macs at my disposal..

I don't know if there is a difference but the difference is I have
View|Character coding->ISO->Western (ISO-8859-15) not 
View|Character coding->ISO->Western (ISO-8859-5).. 

Is there some setup difference..or do you have extensions or fontsmoothing.. 
something that is differnt.  My Mac's are very generic.. nothing but the 
standard extensions.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

18 years ago
This does not happen in 2000-07-24-08 Mac build anymore.
Status: RESOLVED → VERIFIED

Comment 9

17 years ago
Reopening, this is the #5 topcrash for the official RTM build on Mac.  Below is
a stack trace and some user info submitted in talkback reports:

Stack Trace:

	 NQD + 0x19bd0 (0x17f5e370)
	 NQD + 0x116f0 (0x17f55e90)
	 InterfaceLib + 0x1d380 (0xffd1f3c0)
	 nsRenderingContextMac::SelectDrawingSurface()
[nsRenderingContextMac.cpp  line 207]
	 nsRenderingContextMac::Init()
[nsRenderingContextMac.cpp  line 177]
	 nsDeviceContextMac::CreateRenderingContext()
[nsDeviceContextMac.cpp  line 117]
	 PresShell::CreateRenderingContext()
[nsPresShell.cpp  line 3281]
	 PresShell::InitialReflow()
[nsPresShell.cpp  line 2330]
	 DocumentViewerImpl::PrintContent()
[nsDocumentViewer.cpp  line 1016]
	 DocumentViewerImpl::DocumentReadyForPrinting()
[nsDocumentViewer.cpp  line 1368]
	 DocumentViewerImpl::Print()
[nsDocumentViewer.cpp  line 1683]

 	Source File :  line :

	 URL: http://home.excite.com
         URL: northernlight.com
	 URL: www.sol.no
         URL: www.stockhouse.com
         URL: www.webassign.net
        Comment:  trying to print
	Comment:  Print a browser page (a frame)
	Comment:  Wasn't watching.
	Comment:  Used apple-W to close out of a flash enhanced popup window
	Comment:  Trying to Print.  Whenever I try to print from the brower
	Comment:  Trying to subscribe to newsgroups.
	Comment:  attempting to download Canon's Christmas website and Christmas in Sydney
	Comment:  asking for help on setting up the mail server
	Comment:  typing
	Comment:  trying to print website
	Comment:  When I clicked PRINT
	Comment:  Nothing. I were just reading.
	Comment:  attempting to print
Status: VERIFIED → REOPENED
Keywords: topcrash
OS: All
Resolution: WORKSFORME → ---
Summary: Crash at changing Character coding in this site on Mac → RTM Crash (Mac) #5: Crash at changing Character coding in this site on Mac [@ nsRenderingContextMac::SelectDrawingSurface]
(Reporter)

Updated

17 years ago
Keywords: intl
Set milestone to mozilla0.9
Target Milestone: --- → mozilla0.9

Updated

17 years ago
Keywords: nsbeta1
(Reporter)

Comment 11

17 years ago
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong

Comment 12

17 years ago
I can not reproduce this.. is there something about that mac's that crash that 
can help.  I can not do anything if I can not get it to happen.  I know 
smoothfont will crash Macs.. is that part of the recipe.

Comment 13

17 years ago
It works for me with Mac. 01-05-2001 Mtrunk build.
Marking worksforme. Doesn't crash in current build.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 15

17 years ago
Mark as verified. (No crash on 03-30-2001 trunk build)
Status: RESOLVED → VERIFIED

Comment 16

17 years ago
Moving all the Works For Me bugs to talkback user account for future reference.
Assignee: dcone → talkback
Status: VERIFIED → NEW

Comment 17

17 years ago
We are gathering all the Resolved and WFM bugs which are happened to be topcrash 
bugs and assigning it to talkback. I am marking all of them as RESOLVED WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago

Comment 18

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsRenderingContextMac::SelectDrawingSurface]
You need to log in before you can comment on or make changes to this bug.