Frequent instability on netbanking site? (beachballing)

RESOLVED DUPLICATE of bug 351678

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 351678
10 years ago
10 years ago

People

(Reporter: Nathan Bailey, Unassigned)

Tracking

Details

(URL)

Attachments

(7 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.12pre) Gecko/20080122 Camino/1.6b3pre (like Firefox/2.0.0.12pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.12pre) Gecko/20080122 Camino/1.6b3pre (like Firefox/2.0.0.12pre)

In general, Camino seems a little more likely to hang in the last month or two (eg. it just hanged as I was typing this text...!). In particular, though, I've found it regularly unstable with my netbanking website (Westpac). It seems to beachball/hang about 60% of the time, and if I switch away to another application, it is very likely (80%?) to hang). Sometimes it only hangs for 20s or so, but usually it's one minute plus, so I kill it and restart.

Camino just hanged again as I pasted the above text from a text editor (but only for 3-5 seconds).

Reproducible: Sometimes

Steps to Reproduce:
1. Log in to https://olb.westpac.com.au/
2. Switch to another application
3. Switch back and find a hang :-(
Actual Results:  
Camino hangs (beachball)

Expected Results:  
Camino just works, without hanging.

My Camino doesn't seem to generate Talkback reports anymore - is this expected?

Comment 1

10 years ago
Please get a sample of the hang next time it happens:

http://caminobrowser.org/documentation/bugzilla/#hang

describes how.

Attach the resulting file here, using the "Add an attachment" link.

Comment 2

10 years ago
(In reply to comment #0)
> My Camino doesn't seem to generate Talkback reports anymore - is this expected?

Talkback doesn't support Intel, so for your machine it unfortunately is.
(Reporter)

Comment 3

10 years ago
Created attachment 298848 [details]
Activity Monitor.app report of a hang

This is a sample of a hang. Unfortunately, as I was saving this, Camino came back out of the hang (so I'm not sure if this represents it 100% in hang state, or only in hang state for 80% and then last bit is it coming out of hang).

I'll try to provoke some hangs tonight or tomorrow. Thanks for your help so far :-)

Comment 4

10 years ago
While you're at it, it's worth running with a clean profile to see if you can still reproduce this:

http://pimpmycamino.com/parts/troubleshoot-camino

Just drag and drop your Camino onto that icon (quit Camino first, obviously) and then try to reproduce the problem.

Comment 5

10 years ago
Are you still seeing this? If so, could you try grabbing another sample so we can see if the stack is consistent?
(Reporter)

Comment 6

10 years ago
Yes; I got it on my banking site and on this page. On this page, it seemed to be provoked by scrolling down/up with the button on my Mighty Mouse. I tried (only once) with a troubleshoot Camino and neither of these pages crashed.

The most significant thing that is probably different about my Camino is that I keep all my bookmarks in the bookmark bar (ie. there are about 20+ folders with 1400-odd bookmarks, all linked from my bookmark bar; and the bookmark bar has about 30-40 links + folders displaying).

Will play around a little more.
(Reporter)

Comment 7

10 years ago
Created attachment 306161 [details]
ActivityMonitor sample #2

Hang from viewing/scrolling the bugzilla page (ironically, this bug :-)
(Reporter)

Comment 8

10 years ago
Created attachment 306162 [details]
netbank hang (sample one)

First of three samples of the same hang
(Reporter)

Comment 9

10 years ago
Created attachment 306163 [details]
netbank hang #2

Second of three samples of netbank hang
(Reporter)

Comment 10

10 years ago
Created attachment 306164 [details]
netbank hang #3

Third of three samples of netbank hang (thing one about 2-3 minutes after hang started)

Comment 11

10 years ago
Bleh, the hangs are in proxy code under the favicon lookup, so this is probably bug 351678. Do you use a .pac file for proxy setup?
(Reporter)

Comment 12

10 years ago
Ahh. That would make sense with my big bookmark bar. Although it doesn't just happen when I start Camino, sometimes its from task switching (ie. I switch away and switch back) and sometimes from scrolling. I'm about to attach another sample that was happened just from waking up (google.com.au was the only open page).

I don't use a .pac file, I've typed in FTP, HTTP and HTTPS proxies directly.

BTW, I've had a beachball appear about everything 5-8th word in typing the above...
(Reporter)

Comment 13

10 years ago
Created attachment 306178 [details]
Hang on wakeup

Looks like #351678? (Hang on wakeup, only active page was google.com.au). Sample mentions PAC (eg. "nsPACMan::GetProxyForURI(nsIURI*, nsACString_internal&)")
(Reporter)

Comment 14

10 years ago
Created attachment 306179 [details]
Hang on trying to type/submit previous comment

This is the sample from typing comment #12, also mentions PAC (ie. "nsPACMan::GetProxyForURI(nsIURI*, nsACString_internal&)")

Comment 15

10 years ago
Yep, if you have configured proxies, then this would be bug 351678. We really need to revisit the favicon loading system.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 351678
(Reporter)

Comment 16

10 years ago
Thanks for your help in tracking this down, much appreciated! I presume the workaround is simply not to have bookmarks? :-)
You need to log in before you can comment on or make changes to this bug.