Update Firefox application icon on Linux

RESOLVED FIXED in Future

Status

()

--
enhancement
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: faaborg, Unassigned)

Tracking

({polish})

Trunk
Future
x86
Linux
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
We are getting a new app icon, and it needs to be updated on Linux.  This is a spin off bug from 404402
(Reporter)

Comment 1

11 years ago
Let me know exactly what formats and sizes (or vector) we need for this.
Bitmap (.png): 16x16, 22x22, 24x24 (=22x22 + 1px border), 32x32, 48x48

In addition to that, a 48x48 (or bigger) vector image would not hurt. For launchers to pick those icons up they will have to be installed inside the hicolor theme, but I guess this is something for distributions to do.
Forgot one thing:

GNOME is probably going to ship hires artwork at some point, too (my guess would be fall '08), which will be 256x256. So if you have such a version anyway, ship it also for Linux (rendered to PNG).

As for the SVG, I'm not sure how useful that would be on the GNOME desktop, as Illustrator does normally not produce SVGs that work very well using librsvg. I can test this if you send me the icons before they go into CVS.
(Reporter)

Comment 4

11 years ago
Great, we'll try to get the new images by Friday.
How much of this is fixable on Mozilla's end, beyond making artwork available for distros to include at the resolutions they want?
Not much (In reply to comment #5)
> How much of this is fixable on Mozilla's end, beyond making artwork available
> for distros to include at the resolutions they want?

Not much I think, IIRC mozilla.org does not provide installer scripts for FF on linux, right?

Users will have to copy the icons to $HOME/.icons/hicolor/$size/apps/firefox.png manually. They will have to do their own .desktop file, too... so this is not much of a problem.

Just put the new icons into the icons/ directory inside the main folder.
We should ditch mozicon16.xpm and mozicon50.xpm at the same time; looks like we just drop them into /icons in the .tar build, and they're not actually used by us.
I just got a report that Firefox 3.0b4's taskbar icon looks like this
https://bugzilla.novell.com/attachment.cgi?id=202492

I guess that's because the icon is only available as 48x48 currently?
And that's not really distribution specific because we are not talking about icons for desktop menus or launchers but about taskbars which use the window icons.
Yikes. Not sure what's happening there, it looks like someone is scaling up a 16x16 icon to a bigger size. The app icon hasn't been changed yet (afaik), so this might be some side effect from bug 404402. It might help to scribble on the icons in the firefox (eh, make one all red, another all blue, etc) to help figure out exactly which icon is being used here.

I'd file a new bug for this issue, and mark it blocking 404402 for now.

[Also note that https://bugzilla.novell.com/show_bug.cgi?id=371677 indicates this was on KDE.]
(In reply to comment #9)

> It might help to scribble on
> the icons in the firefox (eh, make one all red, another all blue, etc)

Oops.

.... in the firefox directory (eg, make ....

(In reply to comment #9)
> I'd file a new bug for this issue, and mark it blocking 404402 for now.

bug 423426
(Reporter)

Comment 12

11 years ago
In bug 404402 Michael Monreal states in comment 43:

>Recommended sizes for the launcher: 16x16, 22x22, 24x24 (=22x22 + 1px border),
>32x32, 48x48. "Nice to have" would be a highres version (256x256 on GNOME,
>and/or 128x128 for KDE iirc)

To confirm we need png files because we aren't using XPM anymore? (gavin mentioned this might be the case).
We use PNG files in the icons Mozilla loads at runtime for use in the window (bug 404402).

We still ship a 16x16 and 48x48 icon (see comment #7) in the Linux tarballs, but I don't think these are actually used by anything. The icons that appear on the desktop and launcher are an integration issue Linux distros would need to take care of (eg, by having their Firefox package drop icons/settings into the correct place when installed). But I'm not terribly familiar with the magic used to pick an icon in those cases, so I might be wrong.

Updated

10 years ago
Duplicate of this bug: 433167

Comment 15

10 years ago
Hylke Bon has designed a very good Tangoish icon. I propose to use it. Please check attachment.

Comment 16

10 years ago
Created attachment 320399 [details]
Hylke Bon's Firefox app icon

Comment 17

10 years ago
I don't think we need to ship 48x48, just 32x32 is enough. And we should ship 'scalable' version too.

Comment 18

10 years ago
And yes, this icon is for Linux only. So I reckon for Windows and Mac, there will be different icon style and different sizes.

Comment 19

10 years ago
(In reply to comment #13)
> We use PNG files in the icons Mozilla loads at runtime for use in the window
> (bug 404402).
> 
> We still ship a 16x16 and 48x48 icon (see comment #7) in the Linux tarballs,
> but I don't think these are actually used by anything. The icons that appear on
> the desktop and launcher are an integration issue Linux distros would need to
> take care of (eg, by having their Firefox package drop icons/settings into the
> correct place when installed). But I'm not terribly familiar with the magic
> used to pick an icon in those cases, so I might be wrong.
> 

I am not so sure if Firefox follows the same structure as GTK program, but in case it is, you can check the reference page http://live.gnome.org/ThemableAppSpecificIcons . I would help you to understand how the magic pickup the icon.
Please don't spam bugzilla: if you have something useful to say, do it in one comment and not five.

That said, this icon is a non-starter. Firefox only ships with the official Firefox logo. This bug was for tracking Linux icon changes for a new official logo (that plan was postponed, and the current logo isn't changing).
(Reporter)

Comment 21

10 years ago
We'll likely take another shot at this for Firefox 4.

Updated

10 years ago
Target Milestone: --- → Future
Checking in 3.6beta5, this looks like fixed to me regarding the logo used:

/icons/mozicon128.png
/chrome/icons/default/default16.png
/chrome/icons/default/default32.png
/chrome/icons/default/default48.png

the above files are all using the new updated official logo

/icons/document.png which is the "page with a firefox logo inside" still uses the old pre-3.0 logo but maybe this should be in a separate bug? I am not sure this file is used either by Linux and I don't know if the outdated logo problem also exists in Windows.

Somebody mentionned in the comments the possibility of having a 256px version of the logo, I don't know if this is something desired by Linux distros and this might also be the subject of another bug?
Let's call this fixed by bug 492431. This bug's history is a little confusing, because we aborted a plan to update the icon for Firefox 3.0 in 2008, and then updated the icon for Firefox 3.5 in 2009. The icon files in our tree were updated for all platforms.

Bug 504645 should cover document.png, it's almost-but-not-quite unused, just needs some more investigation to see if we can simply remove it.

Bug 495250 or some other one for the 256px icon -- I'm pretty sure we have 2 or 3 bugs floating around for adding more icon sizes for Linux.

Other issues to new bugs, please.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 492431
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.