Closed Bug 413641 Opened 14 years ago Closed 2 years ago

Launch Lightning Release Notes on update of extension

Categories

(Calendar :: Lightning Only, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: klint, Unassigned)

References

Details

(Whiteboard: [not needed beta][has l10n impact])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2 FireShot 0.3 (http://screenshot-program.com)
Build Identifier: Lightning 0.8pre

During last update from Lightning 0.5 to 0.7, many users did not read the Release Notes as the update was proposed automatically by Thunderbird. So, all the known issues were still unknown for them (particularly, the one that would uncheck all calendards and hide data).

So, could it be possible to launch the Release Notes page in the default web browser some time in the extension update process ?

Reproducible: Always

Steps to Reproduce:
1.The extension updater detects a new version of Lightning
2.Install the new version
3.Use the new
Actual Results:  
The release notes are not shown

Expected Results:  
Release notes are shown in the default web broswer the next time Lightning is run.
Or a message pops up : "Do you want to display the Release Notes ? Important information may be found there"
Duplicate of this bug: 413643
Duplicate of this bug: 413642
I think this might be useful. For example the FoxClocks extension <https://addons.mozilla.org/sunbird/addon/1117> already does this similar. After an update a small dialog is displayed and the user can browse to the release notes if wanted.
I was dead sure there was an extension manager bug that allowed displaying release notes automatically when updating an extension, but I can't seem to find it. If someone else does, please mark this bug duplicate against it.
(In reply to comment #4)
> I was dead sure there was an extension manager bug that allowed displaying
> release notes automatically when updating an extension, but I can't seem to
> find it. If someone else does, please mark this bug duplicate against it.

Philipp, maybe bug 459965?
Looks good.

Also it seems there is support for at least showing update information, see:

https://developer.mozilla.org/En/Extension_Versioning%2C_Update_and_Compatibility#Providing_Details_about_Updates

Maybe we can do at least this step for 1.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-calendar1.0+
So it looks like all we need to do is add <em:updateInfoURL> to lightning's install.rdf and let it point somewhere sensible.

Where would this be? Somewhere under http://www.mozilla.org/projects/calendar/lightning/ ? Or maybe on http://live.mozillamessaging.com/ ? 

gozer, sipaq, what do you think?
Looking at the above linked MDC page, we might need to put just the issues page into a somewhat simpler framing, only specific tags are allowed. But generally I think we should show the issues, maybe also a slightly larger opening setence, like "Please read the important known issues before upgrading".
Flags: wanted-calendar1.0+ → blocking-calendar1.0+
Whiteboard: [not needed beta][has l10n impact]

Resolving as WONTFIX as Lightning is now part of Thunderbird.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.