F6 doesn't switch between content and location bar anymore

VERIFIED FIXED

Status

()

Firefox
Keyboard Navigation
VERIFIED FIXED
10 years ago
6 years ago

People

(Reporter: Arjan, Assigned: Aaron Leventhal)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre

Since some time now, pressing F6 will not focus the URI in the location bar anymore. It will instead focus around Larry (pressing enter will show him). 

As I find F6 much less intensive than alt+d, I would like to return to the old-style

Reproducible: Always

Steps to Reproduce:
1. Focus the webpage
2. Press F6
3. 
Actual Results:  
Larry focussed

Expected Results:  
URI in location bar selected
(Reporter)

Updated

10 years ago
Keywords: regression

Comment 1

10 years ago
This comes from making the Identity indicator keyboard accessible - now it's the first tabbable item in the main browser frame, which is what gets the focus through F6. This could thus be WORKSFORME, although it'll feel like a regression to many users nonetheless.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3?
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
I'm all for keyboard a11y, but can't the taborder by changed so the location bar gets the focus first?

Comment 3

10 years ago
This is a result of fix for bug 407359. Aaron, I think having Larry in the tab order before the location bar is good, but could we somehow force the focus to go to the Location bar instead?
(Assignee)

Comment 4

10 years ago
Created attachment 299625 [details] [diff] [review]
Add identity button to tab order only when location bar has focus. Remove from tab order when location bar blurred.

Unfortunately the logic for F6 is hardcoded into nsEventStateManager::ShiftFocusByDocument(). It would be very ugly to specially code for this situation there.

This solution seems to work perfectly well. Once you focus the location bar, either by tabbing or using Ctrl+L/Alt+D, you can shift+Tab to the identity popup. This means that if you shift+Tab out of the document you will now end up at the location bar instead of the identity popup, but that's arguably good. It also means that if you click on the identity button and then hit escape, your focus goes into the location bar -- a behavior I was actually trying to achieve before. So all around I think this works well, although the code needs a comment since it's a bit unexpected.
Attachment #299625 - Flags: review?(mano)
Is it safe to have an element focused when it's set to be not focusable, ESM-code-wise for example?
(Assignee)

Comment 6

10 years ago
(In reply to comment #5)
> Is it safe to have an element focused when it's set to be not focusable,
> ESM-code-wise for example?

Let's ask Mats if he knows of anything. I can't think of anything unsafe about it. 

Comment 7

10 years ago
I don't see any problem with that, it should work fine.
Comment on attachment 299625 [details] [diff] [review]
Add identity button to tab order only when location bar has focus. Remove from tab order when location bar blurred.

ok then.
Attachment #299625 - Flags: review?(mano) → review+
(Assignee)

Updated

10 years ago
Attachment #299625 - Flags: approval1.9?
Comment on attachment 299625 [details] [diff] [review]
Add identity button to tab order only when location bar has focus. Remove from tab order when location bar blurred.

a1.9+=damons
Attachment #299625 - Flags: approval1.9? → approval1.9+

Updated

10 years ago
Assignee: nobody → aaronleventhal
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 10

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008020104
-> VERIFIED
Status: RESOLVED → VERIFIED
Flags: blocking-firefox3?

Comment 11

8 years ago
Fails for me in Firefox 4 beta6, F6 switches focus between page and tab instead.
That's correct behaviour when one has tabs on top, as the tab is the first focusable item in the window.
You need to log in before you can comment on or make changes to this bug.