<hr> %-width settings ignored within tables

VERIFIED DUPLICATE of bug 41306

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 41306
18 years ago
18 years ago

People

(Reporter: was, Assigned: karnaze (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; m16) Gecko/20000602
BuildID:    2000060208

As can be seen at http://www.marginalia.org/test.html - all horizontal rules
within a table basically ignore %-width setting when set by either attribute
(e.g. <hr width="10%"> or stylesheet (e.g. HR {width: 10%;}). If width is set
explicitly (e.g. HR {width: 100px;}) it works correctly.

Reproducible: Always
Steps to Reproduce:
1.Load http://www.marginalia.org/test.html
2.Widths of 1st and 3rd horizontal lines in boxed table should be 10% of table width


Actual Results:  All horizontal rules set by percentage are the entire width of
the table cell.

Expected Results:  All horizontal rules set by percentage should be 10% of the
width of the table cell.
This regressed between 5-16 and 5-17 and is thus a duplicate of bug 41306.

*** This bug has been marked as a duplicate of 41306 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.