Closed Bug 413928 Opened 13 years ago Closed 13 years ago

Hebrew numbering letters displayed in reverse

Categories

(Core :: Layout: Text and Fonts, defect, P2)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: ori, Assigned: smontagu)

References

Details

(Keywords: regression)

Attachments

(2 files, 2 obsolete files)

Attached file test-case (obsolete) —
Using nightly build:

The hebrew numbering displayed with list-style-type:hebrew have the letters in reverse (left-to-right).
See the attached test-case for an example.


Using Firefox 2.0, the letters appear in the correct right-to-left order.

Also note that in 2.0, a different bug is visible:
The dot between the number and the text is in the wrong side: ".<number> <text>".
It is already fixed in trunk.
Assignee: smontagu → nobody
Component: Internationalization → Layout: BiDi Hebrew & Arabic
Flags: blocking1.9?
OS: Linux → All
QA Contact: i18n → layout.bidi
Hardware: PC → All
Assignee: nobody → smontagu
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
I'm already working on this. I have a patch for the bug as reported, but it
regresses the issue mentioned at the end of comment #0:

> Also note that in 2.0, a different bug is visible:
> The dot between the number and the text is in the wrong side: ".<number>
> <text>".
> It is already fixed in trunk.
Status: NEW → ASSIGNED
Attached file Corrected test-case (obsolete) —
I see wrong rendering in Safari (Windows and Mac) in 0 through 4 in the LRT section, but that's because of a missing line in the testcase. This version displays as expected, except that in the RTL section the negative numbers are displayed -3, -2, -1 in the list numbering and 3-, 2-, 1- in the list items (We do the same).
Attachment #299056 - Attachment is obsolete: true
Regressed by bug 370588, according to the regression date.
Blocks: 370588
Attached patch PatchSplinter Review
I really have no choice here but to remove the codepaths for IBMBIDI not defined and for systems with no bidi support, since I have no way to test them.
Attachment #300741 - Flags: superreview?(roc)
Attachment #300741 - Flags: review?(roc)
Why are you removing the hebrewZero support?

Why does mSuffix need to be stored in the nsBulletFrame?
I made a few changes in the algorithm that are reflected in this new testcase. We now use U+05F3 HEBREW PUNCTUATION GERESH to mark numbers >= 1000 and bail to decimal for numbers >= 1,000,000 or < 1 (not 0 as before). Except for 0, this makes us interoperable with Safari.
Attachment #299539 - Attachment is obsolete: true
(In reply to comment #8)
> Why are you removing the hebrewZero support?

The Hebrew numbering system, like the Roman, is old enough that it has no concept of zero, and using the modern word for "Zero" mixed in with the numbers has never made sense to me. We have to bail to decimal for negative numbers anyway.

> Why does mSuffix need to be stored in the nsBulletFrame?

That's preparation for fixing the //XXX comment:
  // XXX For some of these systems, "." is wrong!  This should really be
  // pushed down into the individual cases!
I can cut it for now, if you prefer.
Comment on attachment 300741 [details] [diff] [review]
Patch

Please cut mSuffix for now, yes. r+sr with that
Attachment #300741 - Flags: superreview?(roc)
Attachment #300741 - Flags: superreview+
Attachment #300741 - Flags: review?(roc)
Attachment #300741 - Flags: review+
Blocks: 168944
Checked in, with reftests.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Verified in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050704 Minefield/3.0pre. 
Status: RESOLVED → VERIFIED
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.