Closed Bug 413955 Opened 14 years ago Closed 10 years ago

Compact folders not compatible with user quota filesystems...

Categories

(MailNews Core :: Database, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 195499

People

(Reporter: mederic.ribreux, Assigned: Bienvenu)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.11) Gecko/20061201 Firefox/2.0.0.11 (Ubuntu-feisty)
Build Identifier: Version 1.5 to present...

Description of the problem:
On a corporate environnement, users usually have a limited size home directory (/home or H:\) where the Thunderbird files (profile+mbox files like Inbox and others) are stored.  

In order to physically make room, users have to delete mails and then compact folders. Lots of my users want to do that but they can't as Thunderbird needs at least the same free size on the disk than the mbox to compact file size.

For example, suppose that a user has only 1Gb for his/her home directory, if he as a more than 500Mb Inbox file, he can't compact it. I believe that the problem comes from the fact that Thunderbird (and Mozilla Mail too) try to generate the compacted files on the same path than the files to compact instead of using another path (eg: C:\TEMP, or /tmp).

It could be useful to create an option configuration key indicating a temporary compression file. I've tried to search in the XUL+js code for the compact function but the real function seems to be in the C++ core (messenger.Compact I believe)

Reproducible: Always

Steps to Reproduce:
1. Use a limited size disk or a quota filesystem
2. Fill a mbox file (Inbox or other) with more than half of your limited size
3. Try to compact it (=> Says impossible).
Actual Results:  
Thunderbird says that it can't compact folders because of not enough place on the volume.

Expected Results:  
Should compact it or ask a temporary path to compact before removing old files.
Assignee: nobody → bienvenu
Component: General → MailNews: Database
Product: Thunderbird → Core
QA Contact: general → database
Version: unspecified → Trunk
marking new, i see a problem here 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
Product: Core → MailNews Core
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 195499
You need to log in before you can comment on or make changes to this bug.