VS .NET 2003 fails to build Firefox debug due to new header included from imagelib

RESOLVED DUPLICATE of bug 414042

Status

()

Core
ImageLib
--
critical
RESOLVED DUPLICATE of bug 414042
11 years ago
11 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Bug 411379 added intrin.h to the list of .h files for jdapimin.c . This is apparently not present on my current install. From a Google search it seems like it's a VS 2005 thing only?

Path:

M:\Python25\;M:\mozilla-build\svn-win32-1.4.2\bin;M:\mozilla-build\msys\local\bin;M:\mozilla-build\nsis-2.22\;M:\mozilla-build\msys\bin;M:\mozilla-build\info-zip;I:\Program Files\Microsoft Visual Studio .NET 2003\Common7\IDE;I:\Program Files\Microsoft Visual Studio .NET 2003\VC7\BIN;I:\Program Files\Microsoft Visual Studio .NET 2003\Common7\Tools;I:\Program Files\Microsoft Visual Studio .NET 2003\Common7\Tools\bin\prerelease;I:\Program Files\Microsoft Visual Studio .NET 2003\Common7\Tools\bin;I:\Program Files\Microsoft Visual Studio .NET 2003\SDK\v1.1\bin;I:\WINDOWS\Microsoft.NET\Framework\v1.1.4322;I:\Program Files\ActiveState Komodo Edit 4.2\;I:\WINDOWS\system32;I:\WINDOWS;I:\WINDOWS\System32\Wbem;I:\Program Files\Common Files\GTK\2.0\bin;I:\Mercurial;I:\Program Files\QuickTime\QTSystem\;M:\mozilla-build\moztools\bin;;;I:\Program Files\MiKTeX 2.5\miktex\bin;Q:\lisp

.mozconfig:
# Options for client.mk.
mk_add_options MOZ_OBJDIR=/m/build/firefox-debug/
mk_add_options MOZ_CO_PROJECT=browser,suite,xulrunner

# Options for 'configure' (same as command-line options).
ac_add_options --disable-optimize
ac_add_options --disable-tests
ac_add_options --enable-debug


Build error:
cl -Fojdapimin.obj -c  -DOSTYPE=\"WINNT5.1\" -DOSARCH=WINNT  -I/m/Build/mozilla/jpeg -I.  -I../dist/include   -I../dist/include/jpeg -I../dist/include/nspr    -DLCMS_DLL -I../dist/sdk/include      -TC -nologo -W3 -Gy -Fdjpeg3250.pdb  -DDEBUG -D_DEBUG -DDEBUG_Gijs_Kruitbosch -DTRACING -Zi -MDd           -DWINVER=0x500 -D_WIN32_WINNT=0x500 -D_WIN32_IE=0x0500 -DX_DISPLAY_MISSING=1 -DMOZILLA_VERSION=\"1.9b3pre\" -DMOZILLA_VERSION_U=1.9b3pre -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_X86_=1 -DD_INO=d_ino -DMOZ_EMBEDDING_LEVEL_DEFAULT=1 -DMOZ_EMBEDDING_LEVEL_BASIC=1 -DMOZ_EMBEDDING_LEVEL_MINIMAL=1 -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=browser -DMOZ_XUL_APP=1 -DMOZ_DEFAULT_TOOLKIT=\"cairo-windows\" -DMOZ_THEBES=1 -DMOZ_CAIRO_GFX=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILITY=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_NO_XPCOM_OBSOLETE=1 -DMOZ_XTF=1 -DMOZ_CRASHREPORTER=1 -DMOZ_MATHML=1 -DMOZ_ENABLE_CANVAS=1 -DMOZ_SVG=1 -DMOZ_SVG_FOREIGNOBJECT=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_PLACES=1 -DMOZ_FEEDS=1 -DMOZ_STORAGE=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMOZ_LOGGING=1 -DMOZ_USER_
DIR=\"Mozilla\" -DHAVE_UINT64_T=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF=1 -DMOZ_MORKREADER=1 -DMOZ_DLL_SUFFIX=\".dll\" -DJS_THREADSAFE=1 -DMOZ_REFLOW_PERF=1 -DMOZ_REFLOW_PERF_DSP=1 -DMOZILLA_LOCALE_VERSION=\"1.9a1\" -DMOZILLA_REGION_VERSION=\"1.9a1\" -DMOZILLA_SKIN_VERSION=\"1.8\"  -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT -GL- /m/Build/mozilla/jpeg/jdapimin.c
jdapimin.c
m:/Build\mozilla\jpeg\jdapimin.c(24) : fatal error C1083: Cannot open include file: 'intrin.h': No such file or directory

Comment 1

11 years ago
Just a note that VC2005 is the official Windows compiler for Trunk builds.  Express edition is free for download.

Comment 2

11 years ago
So if we can't work around this we'll need to update:

http://developer.mozilla.org/en/docs/Windows_Build_Prerequisites
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> So if we can't work around this we'll need to update:
> 
> http://developer.mozilla.org/en/docs/Windows_Build_Prerequisites
> 

bug 411379 comment 43 and 44 certainly suggest that this can be done differently...
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414042
You need to log in before you can comment on or make changes to this bug.