Closed Bug 41408 Opened 22 years ago Closed 22 years ago

file -> quite closes all windows without warning

Categories

(SeaMonkey :: General, defect, P3)

x86
All
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 39057

People

(Reporter: djoham, Assigned: asa)

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-15mdk i686; en-US; m16) Gecko/20000602
BuildID:    2000060221

if a user does a file-> quite from any window, all Mozilla instances will also
close without warning.

This is the way that the Linux Netscape version has always worked, but I think
there is a usability issue here that should be addressed.

The Netscape Windows version's menu item is "exit" rather than "quit" which is
think is a more appropriate name. Also in windows, you get a dialog box warning
you of what you are about to do. I think Mozilla should implement this behavior
as well. It may prevent a lot of confused users as "quit" doesn't give any real
indication you are about to *really* quit



Reproducible: Always
Steps to Reproduce:
1.Open test case
2.Press button. A new window will open with CNN.
3.Choose file->quit. All browser instances will close.

perform the same test with Netscape Linux and Netscape Windows. You will get the
same (bad) behavior in Netscape Linux. In Netscape Windows choose "exit" rather
than quit. you will be prompted with a dioalig box confirming your drastic action	

Actual Results:  All windows close on a File->quit	

Expected Results:  A dialog box should ask if you want to close all windows	

I would actually recommend that the quit menu item be replaced with a "close
all" item or some other term instantly idemtifying the purpose of the item. Quit
is not descriptive of what really happens when it is selected.
Attached file easy test case
In your humble opinion, I'm sure.  Confirmation dialogs are the antithesis of
usability for everyday things like quitting Netscape.  Confirmations are only to
be used when you are about to do something extreme, like format your system
partition.

"Close" is for closing a window, "Quit" is to quit using the program.

*** This bug has been marked as a duplicate of 39057 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr
verified dupe of an invalid bug
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.