All users were logged out of Bugzilla on October 13th, 2018

{inc} In xhtml files larger than 100 KB part of the mathml expressions appear with normal instead of italic fonts.

VERIFIED FIXED in mozilla1.9beta3

Status

()

VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: dagan, Assigned: mats)

Tracking

({regression, testcase})

Trunk
mozilla1.9beta3
regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012504 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012504 Minefield/3.0b3pre

In xhtml files larger than 100KB the mathml expressions from a point on start to appear with normal fonts instead of italic. This appears in Mac OSx and in in windows XP. In order to study this effect I created a test file (attached here) with a list of 128 identical mathml expressions. From the 84th the fonts defined as italic, appear as normal. It looks to me that the file is displayed before being fully loaded. Reloading does not help. No errors are displayed.

Reproducible: Always

Steps to Reproduce:
1.Create a larger than 100KB xhtml file with mathml expressions.
2.Run it with Minefield.
3.From a point on the math expressions are displayed with normal, instead of italic fonts.
Actual Results:  
See steps to reproduce above.

Expected Results:  
All the mathml expressions should appear as they are supposed to.

The effect is identical with Mac and with Windows. Sometimes when the computer is just turned on, this effect does not appear, but after reloading the file, it appears continuously.
(Reporter)

Comment 1

11 years ago
Created attachment 299416 [details]
This file is created as a test file. Look in the change of fonts at the 84th expression.
(Reporter)

Comment 2

11 years ago
In all my tests the STIX fonts were used. 

Comment 3

11 years ago
Confirmed on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012604 Minefield/3.0b3pre

Firefox 2.0.0.11 renders the page as intended, adding regression to the bug.
Status: UNCONFIRMED → NEW
Component: General → MathML
Ever confirmed: true
Keywords: regression
Product: Firefox → Core

Comment 4

11 years ago
Also note that the exact location of the italic changeover to normal can move. For me it was near line 8.
Flags: blocking1.9?
QA Contact: general → mathml
Version: unspecified → Trunk
(Assignee)

Comment 5

11 years ago
Regression window: 2008-01-08-04 -- 2008-01-09-04
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-01-08+03%3A00&maxdate=2008-01-09+05%3A00&cvsroot=%2Fcvsroot
Bug 355548?
Blocks: 355548
Summary: In xhtml files larger than 100 KB part of the mathml expressions appear with normal instead of italic fonts. → {inc} In xhtml files larger than 100 KB part of the mathml expressions appear with normal instead of italic fonts.
Attachment #299441 - Flags: superreview+
Attachment #299441 - Flags: review+
Attachment #299441 - Flags: approval1.9+
(Assignee)

Comment 7

11 years ago
Created attachment 299473 [details]
Testcase
(Assignee)

Comment 8

11 years ago
Created attachment 299474 [details] [diff] [review]
reftest.diff
(Assignee)

Comment 9

11 years ago
Created attachment 299477 [details] [diff] [review]
wip2

The first patch makes the parameter redundant so we might as well remove it.
The nsMathMLmoFrame subclass doesn't use the param at all.

http://lxr.mozilla.org/seamonkey/search?string=ProcessTextData
Assignee: nobody → mats.palmgren
Status: NEW → ASSIGNED
Attachment #299477 - Flags: superreview?(roc)
Attachment #299477 - Flags: review?(roc)
Attachment #299477 - Flags: superreview?(roc)
Attachment #299477 - Flags: superreview+
Attachment #299477 - Flags: review?(roc)
Attachment #299477 - Flags: review+
Attachment #299477 - Flags: approval1.9+
(Assignee)

Updated

11 years ago
Attachment #299441 - Attachment is obsolete: true
(Assignee)

Comment 10

11 years ago
mozilla/layout/mathml/base/src/nsMathMLTokenFrame.cpp 	1.67
mozilla/layout/mathml/base/src/nsMathMLTokenFrame.h 	1.21
mozilla/layout/mathml/base/src/nsMathMLmoFrame.cpp 	1.101
mozilla/layout/mathml/base/src/nsMathMLmoFrame.h 	1.33
mozilla/layout/reftests/bugs/414123.xhtml 	1.1
mozilla/layout/reftests/bugs/414123-ref.xhtml 	1.1
mozilla/layout/reftests/bugs/reftest.list 	1.333 

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9? → in-testsuite+
Keywords: testcase
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11
(Reporter)

Comment 11

11 years ago
Sorry Mats, but the bug still appears in Mac and in Windows with Minefield 2008012604. I'll check again in the version of Jan 27. Cheers, Samy
Resolution: FIXED → INCOMPLETE
(In reply to comment #11)
> Sorry Mats, but the bug still appears in Mac and in Windows with Minefield
> 2008012604. I'll check again in the version of Jan 27. Cheers, Samy

Since the patch was checked in on 2008-01-26 18:49, which is after your build was produced, that would be expected. Wait for the next build if you want to test it.

(Also, "INCOMPLETE" is a resolution that means "not enough information for the bug to be useful"; it isn't meant to indicate that the fix didn't work. Use "reopen bug" for that.)
Resolution: INCOMPLETE → FIXED

Updated

11 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

11 years ago
Thanks Mats, Good work! The bug is fixed for Mac and for Windows. Cheers, Samy
You need to log in before you can comment on or make changes to this bug.