Download of Linux Nightly using NT does not work.

VERIFIED DUPLICATE of bug 33808

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 33808
18 years ago
18 years ago

People

(Reporter: Robert Thorneycroft, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m16) Gecko/20000603
BuildID:    2000060308

When selecting to download the Linux nightly build the file that downloads is
actually 24,670K on my PC rather than the 7,267K that the browser implies it
should be.  Also the download speed displays as being about 4 times the actual
bandwidth I have available (I wish), and the percentage download goes way over 100%.


Reproducible: Always
Steps to Reproduce:
1.Go to www.mozilla.org	
2.Download the latest nightly build of the linux browser using the windows browser

Actual Results:  The file downloaded is over 3 times larger than it should be.

Expected Results:  File should be downloaded correctly.

Comment 1

18 years ago
Is this being caused by the auto-ungziping? Theres a seperate bug open for
removing that.

Comment 2

18 years ago
Changing component from "other" to "Browser-General", setting default owner.
Assignee: chofmann → asa
Component: other → Browser-General
QA Contact: leger → jelwell

Comment 3

18 years ago
sounds like the auto-ungzipping. I believe this bug is invalid. Mozilla
uncompresses .gz files when it downloads
them.  I can't find a bug on removing that.

Comment 4

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 5

18 years ago
reporter - does the download work? I've seen this happen before (especailly the 
4 times faster download rate).

going to check into this.



Comment 6

18 years ago
->progress window (?)  I don't really think that's right, though.  who handles 
downloading? networking?
Assignee: asa → evaughan
Component: Browser-General → Progress Window
QA Contact: doronr → sairuh

Comment 7

18 years ago
-->networking
Assignee: evaughan → gagan
Component: Progress Window → Networking
QA Contact: sairuh → tever

Comment 8

18 years ago
This is a dup of a bug I reassigned to Networking yesterday, bug #33808.  For 
some reason (perhaps auto-decompressing that's going on) we get more bytes than 
the content-length indicates.

Maybe if decompressing, the channel should extrapolate a new content-length (or 
at least provide a modified "max" on the progress notifications).  The dialog 
would be a bit flaky (with progress fluctuating and maybe going backward 
slightly).

Comment 9

18 years ago
duplicate of bug 33808

*** This bug has been marked as a duplicate of 33808 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
verified Dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.