repeating tasks are handled improperly

VERIFIED DUPLICATE of bug 350174

Status

defect
--
major
VERIFIED DUPLICATE of bug 350174
12 years ago
11 years ago

People

(Reporter: cehser, Unassigned)

Tracking

Details

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11
Build Identifier: Ltn Nightly 2008210618

When I create repeating tasks, several things happen that I don't expect. 

Especially it is not easily possible to set the current status of a single occurence.

Reproducible: Always

Steps to Reproduce:
1. File->New->Task
2. Set Start Date 16.01.2008
3. Set Due Date 23.01.2008
4. Set Repeat weekly
Actual Results:  
1. Today Pane only shows first occurence
2. If I try to edit the task no "This or all Occurences" dialog comes up, always all occurences are edited
3. Task mode only shows first occurence if "Show All" selected and shows current occurence only if "Show Today" selected
4. Editing a single occurence in Task Mode only shows effect after reload, e.g. after changing to Mail Mode and back.


Expected Results:  
1. Today Pane should show all old uncompleted occurences and the current one
2. It should be possible to edit every single occurence
3. No idea what should be displayed if "Show All" is selected. "Show Today" should behave like Today Pane
4. View should be updated immediately.
Reporter

Comment 1

12 years ago
Just forgot something:

Editing the first occurence is not possible at all.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 350174
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.