Option 'move folders to top of bookmark list'

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Joe Eagar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

It'd be nice to have an option to move all folders to the top of their containing folders/the bookmark list.  This could be an option when right-clicking the containing folder name.

It's very annoying if (like me) you tend to wait a while before finally sorting your bookmarks.  The bookmarks accumulate, and it ends up taking a long time simply to move the folders to the top of the menu.  Especially since I've 
noticed in firefox3 the bookmark organizer list no longer auto-scroll when you
drag an item to the edges.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
This should be fixed by bug 400474 in the meantime. Folders in the menu are grouped on top now, like in Firefox 2.0. Please retest latest trunk:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

The last issue you mentioned is probably Bug 343729. The bug has the blocking 1.9 + flag, so it will be fixed before Firefox 3 comes out.
(Reporter)

Comment 2

10 years ago
I tested on latest cvs yesterday.  Out of five tests, only 3 folders ended up at 
the top, with two or three normal bookmarks between them and the other top 
folders.  I believe where the folder added is defendant upon where in the folder 
list you add the folder (I guess this makes sense); adding to the top of the list 
seems to work as you'd expect.

However you can't rearrange folders in the tree view (i.e. as a cheap way
of moving them all to the top).

Joe
this seems to be WFM now, if not, please file a new bug, not as an enhancement.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.