bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Int chars no longer gets imported correct

VERIFIED DUPLICATE of bug 38844

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED DUPLICATE of bug 38844
18 years ago
14 years ago

People

(Reporter: Henrik Gemal, Assigned: chuang)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
When you import a Netscape 4.73 addressbook (.LDIF) danish chars no longer 
appears correct. A danish "æ" æ get imported as "æ".
This used to work!

Build 2000060308
(Reporter)

Comment 1

18 years ago
The LDIF entry:
dn: cn=Hænrik Gemal,mail=gemal@dk.net
modifytimestamp: 20000223100831Z
cn: Hænrik Gemal
mail: gemal@dk.net
xmozillausehtmlmail: FALSE
givenname: Hænrik
sn: Gemal
objectclass: top
objectclass: person

should give me:
Hænrik Gemal

Comment 2

18 years ago
reassign to chuang. cc momoi.  Kat, do you know if this is happening with other
languages besides danish?
Assignee: putterman → chuang

Comment 3

18 years ago
Looks like a big regression.
Yes, this used to work during M16.I have a build from 
4/16 on my hard disk and it works with my multiligual
data as well as Latin1 & Japanese data imports with .ldif
files. But another build I have from 5/16 exhibits the
same problem Gemal talks about. So does the build from
6/3/2000.
Nominating for nsbeta2.
Keywords: nsbeta2
QA Contact: lchiang → momoi

Comment 4

18 years ago
It looks like we are misconverting UTF-8 data in .ldif files.
(Assignee)

Comment 5

18 years ago
I believe this is the same bug as 38844.  Import utility has convert the UTF-8 
string twice in ldif file.  I have the fix.
Status: NEW → ASSIGNED

Comment 6

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]

Comment 7

18 years ago
This is a dup of bug # 38844

Comment 8

18 years ago
Gemal, I'm going to mark this a duplicate of 38844.
I've marked dependency on that bug. Please check out
your data when that bug gets fixed. I've assigned the
verification task to you. Thanks.

*** This bug has been marked as a duplicate of 38844 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Depends on: 38844
QA Contact: momoi → gemal
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.