Background rendered as black with bit-depth set to "Thousands of Colors"

VERIFIED DUPLICATE of bug 6061

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 6061
19 years ago
10 years ago

People

(Reporter: peter.hunter, Assigned: kmcclusk)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When I set the bit-depth to thousands of colors, the background is rendered as
black and of course I can't read anything. I'm using Gecko/20000603, but this
happened with m15 too.
Does this happen with all pages, or just some?  Is "thousands of colors" 15-bit
or 16-bit?  What's the foreground?
(Reporter)

Comment 2

19 years ago
All pages without a background gif - those with bg gif seem fine. I'm not sure 

whether it's 15 or 16 bit color - if you can tell me how to find that out in 

MacOS I'll let you know. The foreground is fine as far as I can see. I can get 

this absolutely reproducibly by starting in "millions of colors" mode and 

switching to "thousands" or by dragging the window from my monitor (set to 

millions) to my powerbook LCD (set to thousands). I have a Lombard Powerbook 

which has an ATI Rage LT PRO (8 MB of memory), if that helps.

Comment 3

19 years ago
I'm not able to reproduce this problem with Mozilla Build ID: 2000060208 running 
on a PowerMac G3 running Mac Os 8.6.

AFAIK, Thousand of colors on a Mac is 16 bits (65536 colors). Maibe it's because 
it's a PowerBook -- (wild guess). 

*** This bug has been marked as a duplicate of 6061 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
Marking verified dup of 6061.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.