Mousing over the awesomebar drop-down interferes with entering text into the location bar using the keyboard

RESOLVED DUPLICATE of bug 408723

Status

()

RESOLVED DUPLICATE of bug 408723
11 years ago
11 years ago

People

(Reporter: gkn, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
If the mouse pointer hovers over one of the suggestions provided by the awesomebar drop-down, pressing Enter then loads that page.

This is a problem when navigating using the keyboard, if the mouse pointer happens to rest somewhere below the location bar.

For example, (or steps to reproduce:) position the mouse somewhere where the autocomplete drop-down is likely to appear under it (i.e. in the middle of the page, towards the top). Press Ctrl+L to focus the location bar and type “mozilla.org”. Wait for the autocomplete suggestions to appear; then press Enter.

An arbitrary history entry matching “mozilla.org” is highlighted then loaded, instead of loading mozilla.org.

In some cases (I haven't discerned a pattern), an arbitrary matching entry is only highlighted after allowing the awesomebar to return several sets of results, for example by typing “mozilla.org” letter-by-letter. Knocking the mouse a couple of pixels achieves the same effect.

Once an arbitrary matching entry has been highlighted, the arrow keys manipulate its URL instead of what you typed (press left, for example).

This may affect OSes other than Linux; I haven't checked.
Bug 408723, I believe.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408723
You need to log in before you can comment on or make changes to this bug.