Closed Bug 414499 Opened 17 years ago Closed 14 years ago

provide pill shape for consistent buttons

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 559033

People

(Reporter: asa, Unassigned)

References

Details

if we're going to use pill shaped toolbar buttons, shouldn't we be using that same shape for all of our buttons, for example, the toolbar buttons in Places and the Addons Manager?
Component: OS Integration → Theme
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk
QA Contact: os.integration → theme
The initial report seems to be resolved, but morphing to extend it a little.

We should probably provide a default pill shape background for add-ons to use as the background for their buttons.
Summary: [proto] use pill shaped endcaps consistently for buttons → provide pill shape for consistent buttons
(In reply to comment #1)
> The initial report seems to be resolved, but morphing to extend it a little.
> 
> We should probably provide a default pill shape background for add-ons to use
> as the background for their buttons.
> 

We are still using rounded corners in Addons Manager, Error Console, Show Info, and maybe more. Places and the main Browser window are the only ones consistent right now.

We are being a little inconsistent on how we draw these. The browser window is using unique images for each button(button-shape+glyph). The places window has the glyphs overlaying on a button shape background and the rest are being drawn with CSS(with the exception of the gradients).

We could probably work up something default to be more consistent.
I'm working on this.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Blocks: 458197
Target Milestone: Firefox 3 → ---
Er, uh, not really, at least not right now.
Assignee: mstange → nobody
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.