Closed Bug 414519 Opened 12 years ago Closed 12 years ago

Recurring event without gd:when breaks parsing

Categories

(Calendar :: Provider: GData, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mozilla-bugs, Assigned: Fallen)

Details

(Whiteboard: [gdata-0.4])

Attachments

(2 files)

User-Agent:       Opera/9.50 (Windows NT 5.1; U; en)
Build Identifier: TB 2.0.0.9 (20071031), Lightning 0.8pre (2008012418), gcal-provider (latest nightly 2008010811)

I am trying to use my bosses' Google Calendar with Lightning and gcal-provider, but I can only see a fraction of his events, because gcal-provider aborts event parsing upon the first recurring event in his calendar.

He used a tool called "CompanionLink for Google" to export his events from Outlook to Google, which seems to only set a gd:recurrence (that's significantly shorter than what gcal would create) and no gd:when on recurring events.

While Google has no problem with that, gcal-provider stops parsing with the following error message in the log

Error getting items:
TypeError: item.startDate has no properties

Reproducible: Always



Expected Results:  
Ideally, the events should be parsed with the information taken from gd:recurrence. 

Additionally, it would be nice if event parsing would just skip invalid events instead of aborting completely.
Attached file Broken recurring event β€”
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch Fix v1 β€” β€” Splinter Review
Thanks for reporting, I found the problem and a few others on the way. The problem was that the <gd:recurrence> didn't contain VTIMEZONE information (which is ok) and my parsing wrongly stripped all recurrence info, not setting the start time from the DTSTART entry.


r=dbo as discussed.
Assignee: nobody → philipp
Attachment #302820 - Flags: review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [gdata-cvs]
Target Milestone: --- → 0.8
Whiteboard: [gdata-cvs] → [gdata-0.4]
You need to log in before you can comment on or make changes to this bug.