bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

gmail titles shown below label when browser width is reduced

RESOLVED FIXED

Status

()

Core
Layout
--
major
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: stevee, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
x86
Windows XP
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(7 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Created attachment 300009 [details]
screenshot showing problem

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012904 Minefield/3.0b3pre ID:2008012904

1. new profile, start firefox
2. log into gmail
3. reduce the width of the browser window

Expected
- your email titles should always remain on one line, next to the label

Actual:
- label is shown on one line and email title shown below it

Works 20080128_2340_firefox-3.0b3pre.en-US.win32
Broken 20080129_0018_firefox-3.0b3pre.en-US.win32

Checkins to module PhoenixTinderbox between 2008-01-28 23:40 and 2008-01-29 00:17 : 
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1201592400&maxdate=1201594679

Caused by bug 134706 I think
(Reporter)

Updated

11 years ago
Flags: blocking1.9?
The whole contacts list is empty, only the check boxes are there.
testcase reduction love would be great here
This also can be triggered by the bold formatting for unread messages. I had unread messages whose titles were wrapping, but when I marked them as read they stopped wrapping.
Created attachment 300123 [details]
testcase

I managed it to minimize it to this.
Created attachment 300126 [details]
Slightly less minimized testcase
Created attachment 300128 [details]
Even less minimized testcase
Comment on attachment 300123 [details]
testcase

This one is too minimized; we behave the same as Safari and Opera on this one.
Attachment #300123 - Attachment is obsolete: true

Updated

11 years ago
Duplicate of this bug: 414848
Created attachment 300791 [details]
some additional testcases

Actually, Opera's behavior on attachment 300126 [details] is pretty broken -- I didn't notice that the "c" disappeared.

Here's a testcase showing some variations.  I think we're probably best off imitating Safari here, which I think is pretty simple to do.
Created attachment 300833 [details]
some additional tests for white-space:nowrap interaction with block auto-clearing

But on attachment 300128 [details] we match IE (whereas Safari doesn't push the block down and just cuts off part of the contents of the table).

(I haven't tested the last 2 tests here on other browsers yet.)

These are some additional tests related to attachment 300128 [details].
Hrm, so one of the things confusing me is that Safari behavior differs between tables and overflow:hidden divs.  Safari has bug 134706 for the latter, but they don't for the former.
I should also have a variant of attachment 300791 [details] where the empty div has overflow:hidden.
Er, today it seems like Safari has bug 134706 for both; I'm not sure what I was testing yesterday.
Flags: blocking1.9? → blocking1.9-
(Reporter)

Updated

11 years ago
Duplicate of this bug: 417123

Updated

11 years ago
Duplicate of this bug: 417263
Upping to major.
Having an emty list of contacts sucks big time.
I don't understand why you -1.9 this Roc.
Severity: normal → major
Summary: gmail titles shown below label when browser width is reduced. → gmail titles shown below label when browser width is reduced. List of contacts is empty.
(In reply to comment #17)
> I don't understand why you -1.9 this Roc.

He probably did it by accident. I think he meant to + it.

Flags: blocking1.9- → blocking1.9?

Updated

11 years ago
Duplicate of this bug: 417134
Currently we believe that our behaviour is correct as per spec and this bug is INVALID at least as far as Gecko is concerned. David contacted the GMail team, requesting them to fix their code, and it looks like they will.
Oops! Sorry. I forgot about the discussion in this bug (although the conclusion of it wasn't very clear thus far).
Flags: blocking1.9?
In google reader I see the icons for the following (near top left) as on separate lines: Starred items, Trends, Your shared items
This seems like it is probably the same issue as this bug.

Comment 23

11 years ago
(In reply to comment #22)
> In google reader I see the icons for the following (near top left) as on
> separate lines: Starred items, Trends, Your shared items
> This seems like it is probably the same issue as this bug.
> 
I don't think the Google Reader issues are related the Gmail. The GR issues were back to normal in yesterday's nightly (20080229) of Minefield, though, this should not be taken to imply that GR may not have "bad" code.

Comment 24

10 years ago
It has been 2 months since comment #20 about the Gmail team making a change.  Do they have an ETA on this?  Even if its a Gmail issue, it makes Firefox look bad.
for the missing contacts, as workaround you can edit userContent.css and add

@-moz-document domain(mail.google.com) {
.checkable-list .text {overflow:visible: !important; width:auto !important;}
} 

Comment 26

10 years ago
The missing contacts issue was being tracked separately in bug 415252.  It now seems to be resolved for most people (depending on which version of the google site they are hitting...)  The labels issue doesn't, though...

Comment 27

10 years ago
Did they fix it?  the label and the subject looks right now in new version of Gmail(US).

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008041504 Minefield/3.0pre ID:2008041504

Comment 28

10 years ago
(In reply to comment #27)
> Did they fix it?

Nope. It was something on our side between 2008-04-14-06-trunk and 2008-04-15-06-trunk; presumably bug 427129. Going to mark as dependent and resolve as FIXED. I guess people might want to test the bugs this bug blocks, as they may have also been fixed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 427129
Resolution: --- → FIXED

Updated

10 years ago
Summary: gmail titles shown below label when browser width is reduced. List of contacts is empty. → gmail titles shown below label when browser width is reduced

Updated

10 years ago
No longer blocks: 424301

Comment 29

10 years ago
Created attachment 316444 [details]
Problem occurs EVEN when firefox window maximised

Comment 30

10 years ago
(In reply to comment #29)
> Created an attachment (id=316444) [details]
> Problem occurs EVEN when firefox window maximised
> 
wfm with the latest nightly.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008041804 Minefield/3.0pre ID:2008041804

You need to log in before you can comment on or make changes to this bug.