Closed Bug 414569 Opened 14 years ago Closed 14 years ago

AMO Integration: Right-click on extension/theme results in an empty context menu

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9beta4

People

(Reporter: u88484, Assigned: mossop)

References

Details

Attachments

(3 files, 1 obsolete file)

Attached image Screenshot
In the new AMO Integration panel, a right-click on an extension/theme results in a small blank tooltip and no right click menu.  Error console displays:

Error: menus is undefined
Source file: chrome://mozapps/content/extensions/extensions.js
Line: 1641

See screenshot.
Summary: AMO Integration: Right-click on extension/theme results in a very small tooltip → AMO Integration: Right-click on extension/theme results in a very small tooltip and no right click menu
Need to decide what we want in the context menu.
The tit^Wsummary of this bug should be changed. (The popup thingy is a menu, not a tooltip.)
Duplicate of this bug: 417488
Assignee: nobody → dtownsend
Flags: blocking-firefox3?
Summary: AMO Integration: Right-click on extension/theme results in a very small tooltip and no right click menu → AMO Integration: Right-click on extension/theme results in an empty context menu
Not a blocker, at worst its a mild annoyance.
Flags: blocking-firefox3? → blocking-firefox3+
Fail.
Flags: blocking-firefox3+ → blocking-firefox3-
Attached image trivial fix suggestion
This is a proposed fix that is trivial to do and uses only existing strings.
Attachment #305502 - Flags: ui-review?(madhava)
Dave, wouldn't be "Learn More" a better menu entry due to it connects to the link within the extension description?
OS: Windows XP → All
Hardware: PC → All
Comment on attachment 305502 [details]
trivial fix suggestion

Over email, just change the text to Learn More.
Attachment #305502 - Flags: ui-review?(madhava) → ui-review+
Attached patch patch, no accesskeys (obsolete) — Splinter Review
Status: NEW → ASSIGNED
<beltzner> I'd just leave the accesskeys out at this point

This just reuses the existing commands, using the alternate Learn More text for the homepage menu to match the link.
Attachment #305602 - Attachment is obsolete: true
Attachment #305608 - Flags: review?(gavin.sharp)
Whiteboard: [has patch]
Duplicate of this bug: 419693
Attachment #305608 - Flags: review?(gavin.sharp) → review+
Attachment #305608 - Flags: approval1.9?
Comment on attachment 305608 [details] [diff] [review]
no really, no access keys

a=beltzner for 1.9
Attachment #305608 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in toolkit/mozapps/extensions/content/extensions.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/content/extensions.js,v  <--  extensions.js
new revision: 1.163; previous revision: 1.162
done
Checking in toolkit/mozapps/extensions/content/extensions.xul;
/cvsroot/mozilla/toolkit/mozapps/extensions/content/extensions.xul,v  <--  extensions.xul
new revision: 1.71; previous revision: 1.70
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [has patch]
Target Milestone: --- → Firefox 3 beta4
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre.
Status: RESOLVED → VERIFIED
Also verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre ID:2008022704
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.