Closed Bug 4147 Opened 21 years ago Closed 20 years ago

Can't copy text to clipboard using keyboard shortcut

Categories

(Core Graveyard :: Tracking, defect, P2)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 14026

People

(Reporter: cpratt, Assigned: don)

References

Details

Under both Windows 98 and NT 4 SP 4, selecting and then copying text (using both
Ctrl-C and selecting Copy from the Edit menu) does not appear to work - if I
launch Notepad and press Ctrl-V, nothing happens. Nothing appears in the
ClipBook Viewer, either.
Target Milestone: M4
I don't think this is implemented yet, don?
This was (I believe) working at some point in the past. This was found when
trying to regress a bug that had to do with HTML tags being inserted into text
copied to the clipboard...
Target Milestone: M4
Clearing Milestone for don to re-set.
Assignee: don → trudelle
Re-assigned to trudelle@netscape.com.

Peter, Rod is working on this, right?
Assignee: trudelle → rods
Priority: P3 → P2
Target Milestone: M4
RodS owns the new code, which is where this should start working (i.e, not
worth fixing in the old implementation) reassigning to rods as p2 for m4
Status: NEW → ASSIGNED
I own the Windows implementation and the entire infrastructure. I don't own
getting it to work in the Browser. But I have no problem taking on this task. It
shouldn't take much and I have the best understanding of it.
Assignee: rods → sdagley
Status: ASSIGNED → NEW
The copy menu works, but keybindings for menus are not yet implemented. I am
reassigning this to Dagley who own keybindings.
Status: NEW → ASSIGNED
Target Milestone: M4 → M5
saari ran into a brick wall trying to hook the keybind code up to menu commands
on Windows which is going to necessitate rework on all platforms, both by
xptookit and joki, so this is being deferred to M5
QA Contact: 3853 → 4137
cpratt, is this Win32 only?  What are results with Mac and Linux?
This would be masked by bug 4167 (copy doesn't work in browser only) because of a
frameset problem. Is the bug we're talking about that cmd-c, cmd-v don't work, or
that using the menus doesn't' work? Both are totally separate issues and should
be separated.
Summary: Can't copy text to clipboard → Can't copy text to clipboard using keyboard shortcut
Windows:

Copy: The menu item is working. Ctrl-C is not. (Changed this bug's description
to reflect that.)
Paste: The menu item is not working. Ctrl-V is. (Opening new bug for that.)

Linux:

Copy: Neither the middle mouse button, Alt-C, nor the menu item copy.
Paste: Neither Alt-V nor the menu item paste.

Mac OS:

Copy: Neither Command-C nor the menu item copy.
Paste: Neither Command-V nor the menu item paste.
Key binding (i.e. defining key sequences for menu commands) is not connected in
AppRunner for any platform (we could have done it for Mac but the aformentioned
mods required for cross platform usage would have rendered that throwaway
work).  Viewer has key equivalents from some menu commands but the way it is
implemented bears no relation on how it'll be done for AppRunner.
Note: on the Mac, the menu item works if you've selected something in the body
of a HTML document; if you selected something in the URL control, it doesn't.
I've opened a separate bug for that issue.
Target Milestone: M5 → M6
Key binding/commands have been pushed back to M6 when we expect the blocking
issues to be resolved
Target Milestone: M6 → M8
Key binding is now an M8 task
Assignee: sdagley → saari
Status: ASSIGNED → NEW
and on saari's plate
Assignee: saari → don
Keybinding is in, continue shelling of XPApps
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
Target Milestone: M8 → M9
Target Milestone: M9 → M11
Move to M11 for now ...
Target Milestone: M11 → M12
Move to M12 for now ...
Blocks: 19423
Move to M13.
This bug sounds very similar to 14026.  One or the other should probably be
marked a duplicate.  I think 14026 has more information (and is assigned to
davidm right now I think) so we may want to mark this as fixed (since the
keybinding works) or as a duplicate.
QA Contact: cpratt → elig
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Resolved as duplicate.


*** This bug has been marked as a duplicate of 14026 ***
Status: RESOLVED → VERIFIED
Verifying as duplicate; this technically is the first bug, but 14026 is being
actively used by development for tracking.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.