:first-letter is ignored in browser but prints correctly

RESOLVED DUPLICATE of bug 8253

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 8253
10 years ago
10 years ago

People

(Reporter: Andy Boze, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012904 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012904 Minefield/3.0b3pre

One paragraph in the page noted above begins with a drop cap styled by using :first-letter. Although the drop cap displays correctly in IE6 and SeaMonkey 1.1, the first letter of the paragraph lacks any styling in the latest trunk nightlies of SeaMonkey and Firefox, thought the drop cap is printed as expected in both.

Reproducible: Always

Steps to Reproduce:
1.Go to the page noted in the URL.
2.Look at the third paragraph, beginning "Technology is the portal through...".
3.Print the first page of the document.
Actual Results:  
The T in "Technology" is not styled as displayed in the browser. The T is styled on the printed page.

Expected Results:  
The T in "Technology" should be styled as a drop cap as displayed in the browser.
(Reporter)

Comment 1

10 years ago
Created attachment 300260 [details]
PDF shows how printed page appears
(Reporter)

Comment 2

10 years ago
I have another version of the page at http://www.nd.edu/~fboze/ital/sept2007/katz.html . This is without the navigation bars, etc., that get added by the CMS. In this page, :first-letter is not ignored, so the drop cap displays as expected in the browser. I thought this might give a clue as to what the problem might be.

Comment 3

10 years ago
Created attachment 301415 [details]
simplified testcase

The problem seems to involve <link rel="stylesheet"> appearing in the <body> rather than the <head>.  Maybe that's triggering bug 8253?

Comment 4

10 years ago
I'm testing on Mac.

<link> is only allowed in <head> according to the HTML4 spec.  That doesn't excuse Firefox's inconsistent behavior, of course.
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout
Hardware: PC → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 8253
You need to log in before you can comment on or make changes to this bug.