More than one calendars, open mail in new window and accept an invitation -> 'Select Calendar' dialog is empty

VERIFIED FIXED in 0.8

Status

defect
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: andreas.treumann, Assigned: sebo.moz)

Tracking

unspecified
Bug Flags:
blocking-calendar0.8 +

Details

Attachments

(1 attachment)

Reporter

Description

12 years ago
STEPS TO REPRODUCE:
===================

- create more than one calendars in lightning
- open a eMail with an attached invitation via double click in a new window
- push the 'Accept' button

RESULT:
=======

- a empty 'Select Calendar' dialog box comes up

Error Console:

Error: window.opener.getCompositeCalendar is not a function
Source File: chrome://calendar/content/chooseCalendarDialog.xul
Line: 61

EXPECTED RESULT:
================

- the 'Select Calendars' dialog should show all calendars

REPRODUCIBLE:
=============

- always


If I use lightning with only one calendar all works fine (See bug 414631 or 401720).
needs investigation
Flags: blocking-calendar0.8+
Assignee

Comment 2

12 years ago
The same dialog is used for import. Does it work there?
Reporter

Comment 3

12 years ago
@Sebo: Import a ics-file works, the 'Select Calendars' dialog shows all calendars. Same if I try to accept an invitation without opening the eMail in a new window.

Comment 4

12 years ago
Just wanted to add, that even if the message is opened in the Message Pane, if you don't select a calendar (and close the "Select Calendar" window), these errors are produced:

Error: aTargetCalendar has no properties
Source File: file:///C:/Documents%20and%20Settings/My%Name/Application%20Data/Thunderbird/Profiles/vhvw3e3o.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItipProcessor.js
Line: 352

Error: uncaught exception: [Exception... "'[JavaScript Error: "aTargetCalendar has no properties" {file: "file:///C:/Documents%20and%20Settings/My%20Name/Application%20Data/Thunderbird/Profiles/vhvw3e3o.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItipProcessor.js" line: 352}]' when calling method: [calIItipProcessor::processItipItem]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://lightning/content/imip-bar.js :: doResponse :: line 366"  data: yes]
I guess the issue is that in one case the dialog is opened from the main Thunderbird window that has the overlay and knows getCompositeCalendar(). In the failure case the dialog is opened from a different window resulting in the error.
Assignee

Comment 6

12 years ago
calendar-management.js needs to be included in the imip-bar-overlay.
Assignee: nobody → sebo.moz
Status: NEW → ASSIGNED
Attachment #300473 - Flags: review?(daniel.boelzle)
Comment on attachment 300473 [details] [diff] [review]
include calendar-management.js

r=dbo
Attachment #300473 - Flags: review?(daniel.boelzle) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Reporter

Comment 9

12 years ago
Checked in latest nightly build 2008013118 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
VERIFIED

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071031 Lightning/0.8pre (2008020119) Thunderbird/2.0.0.9 ID:2007103104
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
You need to log in before you can comment on or make changes to this bug.