Closed Bug 414897 Opened 12 years ago Closed 12 years ago

Correct capitalization of imipHtml.Comment

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jshatch, Assigned: sebo.moz)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070730 SUSE/2.0.0.6-25 Firefox/2.0.0.6
Build Identifier: 2008011808

If a calendar message was delegated in Groupwise the message pane is blank and only shows a single attachment entitled "Part 1.1".  This worked as of build 2008011704 and hasn't worked since 2008011808.

Reproducible: Always

Steps to Reproduce:
1. Install build 2008011808 or later
2. use Groupwise to delegate a calendar item
3. view the message.  It will show up blank
Actual Results:  
The message pane is blank

Expected Results:  
I should see the calendar item and be able to accept it.

I'll attach a screenshot along with a sample of a message that does not work.
Do you see any calendar related error messages in the Error Console?

Checkins during regression range from Comment #0: http://tinyurl.com/2g63yf

From a first glance the only checkin related to itip/imip invitation handling is Bug 387863.
Yes, bug 387863 might be the causer. It added the following code:

/calendar/lightning/components/lightningTextCalendarConverter.js, line 139 --
    labelText = stringBundle.GetStringFromName("imipHtml.comment");
/calendar/locales/en-US/chrome/lightning/lightning.properties, line 56 --
    imipHtml.Comment=Comment:

Notice the different capitalization of "imipHtml.Comment". I guess GetStringFromName() throws an error in this case.
I see a lot of these messages:

Error: imipMethod has no properties
Source File: chrome://lightning/content/imip-bar.js
Line: 168

but these seem to happen on messages that display correctly...

Clearing the error console and looking at the email in question I get:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///home/jarom/.thunderbird/0yjp3795.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js :: createHtml :: line 136"  data: no]
Source File: file:///home/jarom/.thunderbird/0yjp3795.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js
Line: 136

My attempts to reproduce it with my account have failed.  The messages that are
in question I cannot provide to you since they are company emails.

I hope the error output helps.
Confirming bug and marking as regression.
Blocks: 387863
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-calendar0.8?
Keywords: regression
Attached patch patchSplinter Review
Since we are in string freeze I changed this to imipHtml.Comment.
We should revert both to small letter after the release.
Assignee: nobody → sebo.moz
Status: NEW → ASSIGNED
Attachment #300437 - Flags: review?(ssitter)
Comment on attachment 300437 [details] [diff] [review]
patch

r=ssitter
Attachment #300437 - Flags: review?(ssitter) → review+
Attached file testcase
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Flags: blocking-calendar0.8?
Summary: Groupwise Delegated messages do not display at all → Correct capitalization of imipHtml.Comment
Component: General → E-mail based Scheduling (iTIP/iMIP)
QA Contact: general → email-scheduling
You need to log in before you can comment on or make changes to this bug.