Last Comment Bug 414928 - Black image when scaled to fit
: Black image when scaled to fit
Status: RESOLVED DUPLICATE of bug 411831
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://dunechaser.blogspot.com/2006/0...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 12:23 PST by Mark Stokes
Modified: 2008-06-20 03:33 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of the image problem. (171.24 KB, image/jpeg)
2008-01-30 12:26 PST, Mark Stokes
no flags Details
An image from theoildrum.com (104.79 KB, image/png)
2008-03-13 13:47 PDT, crf
no flags Details

Description Mark Stokes 2008-01-30 12:23:08 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2008012817 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2008012817 Firefox/3.0b2

When visiting webpages I find some images are black. It seems some scaled images are not working. If I view a large image and firefox3 scales the picture to fit in the browser window I get a black image. Viewing a picture at the original size is no problem. I find this problem shows up frequently on ebay auctions as the thumbnail image at the top is just a rescaled image of a larger picture lower down the page. 

Reproducible: Sometimes

Steps to Reproduce:
1.Look for images that have been rescaled to fit.
2.ebay actions 1 in 10 auctions seem to be affected.
3.
Actual Results:  
Instead of seeing a image I get a 100% black image

Expected Results:  
I would normally see the correct picture

I am using Linux. I am using the xf86-video-ati driver. I have posted this issue on the Archlinux forums others seem to be having the same problem. 1 other poster was using intel driver.
http://bbs.archlinux.org/viewtopic.php?id=43127
Comment 1 Mark Stokes 2008-01-30 12:26:26 PST
Created attachment 300448 [details]
Screenshot of the image problem.
Comment 2 Maximilian Mehnert 2008-02-14 22:12:46 PST
Same for me using beta3 on debian
Comment 3 Ray Lee 2008-02-17 14:10:57 PST
Ditto with the black images. I'm using latest xserver-xorg-video-ati, on ubuntu latest (hardy heron development snapshot).

In addition to the above, I'm also seeing odd corruptions where portions of other off-screen bitmaps are getting reused in situations where firefox appears to expect an empty bitmap to exist. This only happens after many images have been browsed through, such as in an image gallery.

I don't know, the latter smells like some sort of refcount problem, while the former appears to be firefox using the video driver to resize and it, perhaps, doing the wrong thing?
Comment 4 John Drinkwater (:beta) 2008-03-03 09:46:43 PST
I was brought here via the comments on :
http://blogs.sun.com/richb/entry/more_firefox_3_weirdness#comment-1204564956000

Does the suggestion of updating your cairo libs fix the issue or is it unrelated?
Comment 5 Rich Burridge 2008-03-03 10:05:18 PST
@John: "Does the suggestion of updating your cairo libs fix the issue or is it
unrelated?"

No. See my new comment to that blog post.

Comment 6 Joanmarie Diggs 2008-03-03 10:41:38 PST
> In addition to the above, I'm also seeing odd corruptions where portions of
> other off-screen bitmaps are getting reused 

I've seen this when using Netvibes.  I can no longer reproduce the problem.  But when I could, it was strictly with the beta that came with Hardy.  On the same boxes, if I grabbed the latest FF trunk or built FF from source the problem wouldn't happen.  Is there any chance it's something the distro is (or isn't) doing?
Comment 7 Patryk Zawadzki 2008-03-04 02:34:43 PST
I'm experiencing something similar using the latest intel driver (both EXA and XAA but seems to happen more often using XAA).

Also rendering this page displays various parts of my desktop or the previous page instead of showing the build log: http://buildlogs.pld-linux.org/index.php?dist=th&arch=x86_64&ok=0&name=openoffice.org
Comment 8 david.hagood 2008-03-12 17:56:03 PDT
I just pulled the 3b4 for Linux, unpacked it, wiped out (well, moved out of the way) my ~/.mozilla/firefox/* profile directory, and went to http://www.herdthinners.com - and saw the problem. This happens no matter what the DPI setting of my environment is, although by default I run a 149 DPI display.

Comment 9 crf 2008-03-13 13:47:21 PDT
Created attachment 309208 [details]
An image from theoildrum.com

I see this all the time. It comes and goes though!
Also, perhaps related, some images partially load, with the rest black, or load misaligned in their boxes (the image is shifted downward in its box). It seems to happen for images that are resized.

I'm using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031304 Minefield/3.0b5pre
Comment 10 Andrew 2008-03-16 21:13:42 PDT
same problem, using fglrx driver on r600 video card, Viewsonic VP191b monitor.

Some images are black, some partially load.
Comment 11 Damjan Georgievski 2008-03-22 11:58:59 PDT
Still the same problem with 3.0b5pre. I use xf86-video-intel 2.2.1 with XAA. Images are pratly or fully black when Firefox resizes them.

BTW, why is this bug Unconfirmed yet?


Mozilla/5.0 (X11; U; Linux i686; mk; rv:1.9b5pre) Gecko/2008032104 Minefield/3.0b5pre
Comment 12 Matthias Versen [:Matti] 2008-03-26 13:20:09 PDT

*** This bug has been marked as a duplicate of bug 411831 ***
Comment 13 Leon 2008-06-20 03:17:37 PDT
Same (black boxes on scaled images) here, using FF3.0 and radeon driver

xf86-video-ati-6.8.0-i486-1 Slackware-current package
xorg-server-1.4.0.90-i486-1 Slackware-current package
ATI Radeon Mobility M7 LW [Radeon Mobility 7500]

Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0
Comment 14 Leon 2008-06-20 03:33:03 PDT
(In reply to comment #13)
> Same (black boxes on scaled images) here, using FF3.0 and radeon driver
> 
> xf86-video-ati-6.8.0-i486-1 Slackware-current package
> xorg-server-1.4.0.90-i486-1 Slackware-current package
> ATI Radeon Mobility M7 LW [Radeon Mobility 7500]
> 
> Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0
> 
Sorry for bugging... is already solved.

Note You need to log in before you can comment on or make changes to this bug.