dismissing alarm on single instance of recurring event deletes alarm on all instances

VERIFIED DUPLICATE of bug 397030

Status

--
major
VERIFIED DUPLICATE of bug 397030
11 years ago
11 years ago

People

(Reporter: benjamin.lerner, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Lightning 0.8pre (2008012918), GData 0.4pre (CVS nightly as of 1/30/08)

When using recurring events, alarms are useless if they don't apply individually to each instance.  Dismissing the alarm for a single instance dismisses them *all* for past, current, and future instances of the event.

Reproducible: Always

Steps to Reproduce:
1. Create a recurring event, and set an alarm for all instances
2. Wait for one instance's alarm to go off
3. Dismiss the alarm
Actual Results:  
All past and current alarms appear in the Alarms window.
All alarms -- past, current, and future -- get dismissed, and so future instances of the event have no alarms.

Expected Results:  
Only the current alarm should be dismissed.  Past alarms should be dismissable individually, or via Dismiss All, but not by dismissing a single instance.

I'm using a Google Calendar with the latest nightly GData provider.

Hopefully this isn't a dupe; I couldn't find another bug on Alarms that seems to match this problem...
Is there a difference to bug 397030?
(Reporter)

Comment 2

11 years ago
Thanks for the link -- I'd searched for "alarm repeating event" (without quotes!) but that bug didn't come up for me...  Resolving as duplicate
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397030
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.