Closed Bug 415027 Opened 14 years ago Closed 12 years ago

Display URL field when viewing individual crash reports

Categories

(Socorro :: General, task, P3)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: alqahira, Assigned: ozten)

References

Details

(Whiteboard: admin-panel)

Attachments

(1 file)

It's very useful for QA if the URL of the crashing page is displayed as part of the report (especially on reports with comments, as comments can often be STR).  This enables QA and developers to visit the URL and attempt to reproduce the crash.
We explicitly disabled this before we had the URL checkbox.  I agree that it's nice to have, but I don't know if we can confidently do this yet.
shaver: I know you were big on hiding them before.  Do you still think it's important now that we allow people to opt out of sending it?
I don't think we should display them publicly, as we didn't with talkback, but providing a view for trusted QA folk would seem reasonable.  If the default is to not send the URL, and people have to explicitly opt into it, _and_ it's made clear that the URL will be publicly displayed to help with testing and bug investigation, then I could probably get onside with it.

I very very much hold that informed consent and protection of the user's privacy _must_ outweigh even the most mind-warpingly valuable developer convenience.
> I don't think we should display them publicly, as we didn't with talkback

We actually did/do display URLs that users provided in talkback reports, but it was information the user typed in

http://talkback-public.mozilla.org/reports/firefox/FF20012/simple-crash-analysis.all

not information that we automatically gather up and send on their behalf.

I agree about the privacy parts.  Should we switch back to having users type in the URL of the site or page as a way to opt in?   Can we get a private reporting site up and going quickly?   I'm ok with either, but we really need URL analysis to zero in on major problems and problem sites.

I think automatically collecting the URL is a huge win. I think an aggregate URL report would be great, as well as a way for logged in users to view URLs on reports. I don't know what the timeframe for either of those would be.
I agree that automatic collection of the URL is a huge, huge win.  On the other hand, since no one can see them, it's doing absolutely nothing for us right now and is a net loss compared to clunky ol' Talkback.  Can the Socorro changes mentioned, at least to let "logged-in users" see the URLs in reports, be given some sort of priority?  

It's tough dealing with web-content-related crashes without URLs; even if you get a comment to accompany the stack, you still only have "half" of the picture.  Moreover, I've seen a couple of cases (which the "the world is good" person in me hopes are isolated aberrations) recently where Mozilla devs wouldn't even look at topcrash bugs that QA filed unless QA provided testcases or really solid STR.  Without URLs, it's nearly impossible to come up with a testcase or a working STR for a web-content crash.  You might have the steps from a comment, but not the URL you need to actually turn those steps into a reproducible crash.

WRT to logging in, I hope the plan is/will be to let anyone we trust with source code repository commit access (plus the QA teams, if such exist, of any mozilla.org project shipping breakpad, since QA folks often don't have VCS access) have access to the URLs-as-part-of-individual-reports.
> I don't know what the timeframe for either of those would be.

how can we figure this out?  having two reporting systems in place (one with auth, and one not) is a bit of a pain, but that sounds like the direction we need to go to get this moving.

who has cycles to work on this now, and what priority could we assign it?
Priority: -- → P3
Behind auth only.
Severity: normal → enhancement
Summary: Display URL field in reports → Display URL field in when viewing individual crash reports
Summary: Display URL field in when viewing individual crash reports → Display URL field when viewing individual crash reports
Whiteboard: admin-panel
(In reply to comment #9)
I'm starting to work on LDAP and reusing MCC's Kohana Auth module.
Depends on: 522349
Assignee: nobody → ozten.bugs
Target Milestone: --- → 1.3
Status: NEW → ASSIGNED
Comment on attachment 419985 [details] [diff] [review]
First stab: Adds the URL to the crash display for logged in users

Looks good!
Attachment #419985 - Flags: review?(ryan) → review+
Sending        webapp-php/application/models/report.php
Sending        webapp-php/application/views/report/index.php
Transmitting file data ..
Committed revision 1674.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.