[UI] Drag & drop in bookmarks menu needs improvement

RESOLVED DUPLICATE of bug 389290

Status

()

RESOLVED DUPLICATE of bug 389290
11 years ago
9 years ago

People

(Reporter: cpuidle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008013004 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008013004 Minefield/3.0b3pre

On windows platform, drag & drop in bookmarks menu shows dragged item highlighted and overlaying other bookmarks. It is not immediately obvious where the bookmark is actually dropped. Also, it is not possible to drag bookmarks to a sub folder.

I'm suggesting two improvements:
- added a divider similiar to the bookmarks sidebar to show drop target position
- enable bookmarks menu to drag&drop into/across sub folders


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Any chance looking into this? Functionality is way below par to eg. IE?

Comment 2

11 years ago
draggin into subfolders is thread manager core bug but mostly this is bug 389290
Component: Bookmarks → Places
QA Contact: bookmarks → places

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389290
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.