Closed Bug 415227 Opened 13 years ago Closed 13 years ago

Slow response on initiation of downloads when download manager list is long

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 159107

People

(Reporter: cdokolas, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

While the list of finished downloads in the download manager increases there are increasing delays before the download dialog appears and after the OK button is pressed (before the download appears in the download manager list).

Specifically: user clicks on a download -> browser does something (gets headers?) -> delay (browser does not respond) -> download dialog appears (asking what to do with the file) -> OK is pressed -> another delay (browser does not respond again) -> download appears in download manager OR download finishes (notification pop-up) if the file is small

The delay (and browser momentary freezes) is increassingly noticeable when the list reaches several tens of entries. I realized just yesterday what was happening (I thought it was some kind of network problem) when I cleared the list, so I don't know how many entries there were, but I would assume there were more than 100 entries. The delays where each in the order of 5 to 8 seconds.

Reproducible: Always

Steps to Reproduce:
1. Populate (somehow) the download manager list with lots of entries (at least 100?)
2. Observe how the whole download process (the interactive part) slows down
3. Clear the download manager list
4. Browser responds normally (no noticeable delays)
Actual Results:  
Increasing delays before and after the download dialog


NO delays, whatever the size of the list
The last bit should have been:

Expected Results:
NO delays, whatever the size of the list
That will be fixed in Firefox 3. A workaround in Firefox 2 is to make sure that the list doesn't become to long.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 159107
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.