Closed Bug 415437 Opened 14 years ago Closed 14 years ago

Esc no longer dismisses autocomplete popup menu

Categories

(Camino Graveyard :: Location Bar & Autocomplete, defect)

All
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Camino2.0

People

(Reporter: bugzilla-graveyard, Assigned: jaas)

References

Details

(Keywords: regression)

You can no longer dismiss the autocomplete results popup menu with the Escape key. This worked back in a 21 Dec branch nightly (the latest branch nightly I have) and this used to work on trunk around the same time; it's definitely broken in the latest trunk, probably by bug 409634.
Urgh. My connection is crap, and I missed bug 346471, which is much more likely to be the cause of this.
Blocks: 346471
No longer blocks: 409634
OK, did some more testing. This works on the latest branch, but still fails on trunk 2008020300. Marking trunk-only.
Version: unspecified → Trunk
Yeah, I do see this in my trunk build.

I guess we need to fing the actual range while this is fresh on our minds.
Target Milestone: Camino1.6 → Camino2.0
The regression range eliminates bug 346471 as a cause of this; sorry for the trouble, Mark :)

This works in 28 January but broke in 29 January, which makes me suspect bug 376077.

I'd love it if someone would explain to me how changes to Cocoa widget code managed to break Esc in an AutoCompleteTextField.
Blocks: 376077
No longer blocks: 346471
This is fixed by the patch for bug 358379.
Depends on: 358379
Assignee: nobody → joshmoz
patch for bug 358379 landed, this is fixed
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: tracking1.9? → blocking1.9?
This seems fixed in my own build after bug 358379; we should verify using the official nightly.
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
v. with 2.0a1pre (1.9b4pre 2008030203)
Status: RESOLVED → VERIFIED
Clearing the blocking1.9? nomination since this is fixed again.
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.