site takes five minutes to render on Athlon 1800.

UNCONFIRMED
Unassigned

Status

()

Core
Layout
UNCONFIRMED
10 years ago
5 years ago

People

(Reporter: arromdee2@yahoo.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

The site takes unacceptably long to render.  This problem also happens on other pages (like movie detail pages).  My queue has 188 movies at the moment and takes five minutes.

Reproducible: Always

Steps to Reproduce:
1.Log in to Blockbuster Online (will require a person with an account)
2.Go to queue with lots of entries (I had 188 items)
3.Notice how long it takes to render
Actual Results:  
Rendering the page takes five minutes

Expected Results:  
Rendering the page should have taken less than five minutes

Theme is default.
OS is Mandrake 10.1.
Processor is Athlon 1800 slightly underclocked
This will be difficult to confirm because you need an account.
How are other browser performing on this page ?
Is it possible that you save the page and attach it as testcase (I don't know if it contains personal informations).
(Reporter)

Comment 2

10 years ago
My queue really doesn't contain anything so embarrassing that I can't take a small risk of letting you guys see it, so I put a copy of the page at http://www.rahul.net/fullQueue.htm .  The problem seems entirely caused by movies.css; deleting it makes the problem (and the formatting) go away.

If I try reproducing it on a local copy, my CPU is pegged at 100% and Firefox locks up for 18 seconds.

If I try it on a remote site, I get the same 5 minute lockup I get at the original site.

The five minutes seems to be connected to the fact that I'm on dialup.  My guess from the observed behavior is that since I'm on dialup, it takes long enough to load the page that many partial pages are drawn.  Each partial page takes another 18 seconds and they all happen one after another, adding up to five minutes.

So I *suspect* that the real problem is the 18 seconds of lockup and if you fix that, it'll also fix the five minutes.

Notice that even on a local copy, there's other weird behavior.  For instance, load the page and wait the 18 seconds for it to render.  Then open up the File menu at the top of Mozilla.  Opening this menu covers some of the page, causing it to take another 18 seconds before you can use the File menu.

I tried this at work on a Windows PC using IE.  It works fine and doesn't take more than a second at most.
I get a 404 for your URl :
The requested URL /fullQueue.htm was not found on this server.
Apache/1.3.27 Server at www.rahul.net Port 80
Could be DOM or layout or something else.
Someone needs to analyze this, it's only a little bit slow on my Intel Quad-Core
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
(Reporter)

Comment 6

10 years ago
I tried it again on Firefox 3 beta 3.  The problem no longer happens.

However, I now get delays on http://tvtropes.org/pmwiki/ykttw.php which I didn't on Firefox 2.  This one gives me 25 seconds of 100% CPU when I load it, and whenever I scroll down a page, another second or so of 100% CPU time.  Which isn't as bad as the Firefox 2 problem, but still not all that great.  Again, the large amount at the start seems to be caused by having to redraw the page several times; when I try it on a local copy I just get a second at the start and a second every time I try to scroll down.
(Reporter)

Comment 7

10 years ago
The problem in comment 6 still happens in beta 4 and beta 5.
(Reporter)

Comment 8

10 years ago
The problem in comment 6 still happens on RC1.  It isn't the only site this happens on, either; this one is just a little more egregious than most.  It's just about impossible to scroll down on this page because attempting to do so immediately pegs the CPU to 100% for several seconds trying to redraw it.

You can easily see the behavior just trying to scroll on it; dialup isn't necessary (though it certainly can make the original problem worse.)
(Reporter)

Comment 9

10 years ago
I now have an Athlon XP 4850.  I no longer get the problem (using the same Firefox binaries), although if I scroll the page fast there is the occasional jump to high CPU usage.

This may be because the computer is three times the speed (the 1800 was a bit underclocked).  It could also be because I reinstalled Linux and am using different GTK libraries.  I don't know.  If it is just the speed, this could still be a problem for people with slower machines.
This seems to be pretty fast for me
You need to log in before you can comment on or make changes to this bug.