Add Japanese locale to Calendar

VERIFIED FIXED in 0.8

Status

enhancement
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: dev-null, Assigned: dev-null)

Tracking

unspecified

Details

Attachments

(1 attachment)

Assignee

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; ja-JP-mac; rv:1.9b3pre) Gecko/2008020304 Minefield/3.0b3pre Firefox/3.0b
Build Identifier: 

I've checked in Japanese l10n files to cvs.
# Thanks to mike-san!

Please add them (ja for Win and Linux, ja-JP-mac for Mac) to Calendar.

Reproducible: Always
Assignee

Comment 1

12 years ago
Attachment #301236 - Flags: review?(bugzilla)
Comment on attachment 301236 [details] [diff] [review]
Add Japanese locale

>Index: calendar/locales/shipped-locales
>===================================================================
>diff -u -r1.1.4.12 shipped-locales
>--- calendar/locales/shipped-locales	29 Dec 2007 20:45:03 -0000	1.1.4.12
>+++ calendar/locales/shipped-locales	4 Feb 2008 07:37:45 -0000
>@@ -9,6 +9,8 @@
> ga-IE
> hu
> it
>+ja win32 linux
>+ja-JP-mac osx
> ka
> ko
> lt

I don't understand the additional arguments that you're setting here in the file. Are these just comments or do these have another role?
Assignee

Comment 3

12 years ago
(In reply to comment #2)
> I don't understand the additional arguments that you're setting here in the
> file. Are these just comments or do these have another role?

Not only comments.
It is same as Firefox and Thunderbird.
http://mxr.mozilla.org/mozilla1.8/source/browser/locales/shipped-locales
http://mxr.mozilla.org/mozilla1.8/source/mail/locales/shipped-locales

For example, please see http://www.mozilla.com/en-US/firefox/all.html
Japanese locales of Firefox are
Windows : http://www.mozilla.com/products/download.html?product=firefox-2.0.0.11&os=win&lang=ja
Mac OS X: http://www.mozilla.com/products/download.html?product=firefox-2.0.0.11&os=osx&lang=ja-JP-mac
Linux   : http://www.mozilla.com/products/download.html?product=firefox-2.0.0.11&os=linux&lang=ja

As well as Firefox,
only Sunbird ja for Windows, ja-JP-mac for Mac OS X and ja for Linux should be shipped.
Sunbird ja for Mac OS X ,ja-JP-mac for Windows, ... should not be shipped.

Comment 4

12 years ago
My 2cts, I'd add Japanese to the builds, then test and QA the generated builds, and then add it to shipped-locales.

But that's on the assumption that shipped-locales is used as such for Calendar, and that the Calendar thinks so, too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 301236 [details] [diff] [review]
Add Japanese locale

Thanks for the explanation.

r=sipaq

Axel, we normally add the respective entries to both files at the same time and remove them eventually from shipped-locales if a serious issue arises.
Attachment #301236 - Flags: review?(bugzilla) → review+
Assignee: nobody → dev-null
Status: NEW → ASSIGNED
>+ja win32 linux
>+ja-JP-mac osx

I fear this might break our scripts. We currently assume that shipped-locales contains only one locale per line and no extra parameters. Parsing this file will make our build scripts believe that there is a locale win32, linux and osx.

I understand the japanese language is quite complex, but I'd nevertheless like to ask why its not possible to have one "ja" locale for both win,linux,mac.

Comment 7

12 years ago
I suggest to fix your scripts to parse shipped-locales as intended.

The platform specifiers are not only used for Japanese, but also for locales with stop-ship problems on particular platforms.

Re Japanese, for hysterical reasons, macs and non-macs use a different computer language, for example in menu entries. AFAIR.
Yes, we should fix the corresponding scripts. The issue of Japanese being available in two different languages depending on the system platform is longstanding and cannot be changed by us.
Patch checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Assignee

Comment 10

12 years ago
(In reply to comment #9)
> Patch checked in on HEAD and MOZILLA_1_8_BRANCH.

I confirmed ja and ja-JP-mac 1.8branch tinderboxen are green.
Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.