Successfull installation of bugzilla 3.0.2 on w/ lighttpd

UNCONFIRMED
Unassigned

Status

()

Bugzilla
Documentation
--
enhancement
UNCONFIRMED
10 years ago
3 years ago

People

(Reporter: Claude-Sebastien Jean, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20080127 Firefox/2.0.0.11
Build Identifier: 3.0.2

Running a linux gentoo server and I have succesfuly installed a bugzilla server on lighttpd server.

Following the advice in the documentation, here are the simple steps to setup bugzilla.

1- Install bugzilla in the http server root.
2- Enable mod_cgi server module:
-------------
/etc/lighttpd/lighttpd.conf
     server.modules += ("mod_cgi")
-------------
3- Add the following lines to the /etc/lighttpd/lighttpd.conf
-------------
/etc/lighttpd/lighttpd.conf
$HTTP["url"] =~ "^/bugzilla/.*" {
    # disable directory listings
    dir-listing.activate = "disable"
    # only allow cgi's in this directory
    cgi.assign = ( ".cgi" => "" )
    index-file.names   = ( "index.cgi" )

}
-------------

4- restart lighttpd ...

And voila.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Unfortuntaely, there are still problems with this -- for example, localconfig and data/params are available for download over the web, which is not a good idea!

Comment 2

10 years ago
Is this something that would be better for the wiki? i.e. is Bugzilla isn't "officially supporting" lighthttpd, maybe we can have it there instead of in the docs?

Comment 3

9 years ago
From #mozwebtools:

  ""-T" is on the #! line, it must also be used on the command line at /srv/www/bugzilla/index.cgi line 1."

Looks like taint mode is not directly supported by lighttpd:

http://redmine.lighttpd.net/issues/show/1685
The bug referenced in comment 3 has been closed as WONTFIX.

Gerv

Comment 5

4 years ago
To avoid the -T error, here is the trick with lighttpd :

# in your shell :
echo "#!/bin/sh\nexec perl -T $@" > /usr/sbin/perl-taint-cgi
chmod a+rx /usr/sbin/perl-taint-cgi

# in lighttpd config :
cgi.assign = ( ".pl" => "/usr/sbin/perl-taint-cgi" )

Comment 6

3 years ago
If somehow you arrive at this bug and you are trying to use Bugzilla on Windows, you need to set the ExecCGI/Command key in the Windows registry to "perl.exe -T"
You need to log in before you can comment on or make changes to this bug.