Closed Bug 415530 Opened 14 years ago Closed 14 years ago

Error: this.mInput.removeAttribute is not a function

Categories

(Toolkit :: XUL Widgets, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: zeniko, Assigned: frnchfrgg)

References

Details

(Keywords: regression)

Steps to Reproduce:
1. Go to www.google.com
2. Search for "firefox"
3. Now enter "fyi" into Google's search field (so that at first "firefox" is suggested and then there are no more suggestions available)

Actual result:
When the autocomplete popup is hidden (as there are no more suggestions available), the following error is thrown:

Error: this.mInput.removeAttribute is not a function
Source File: chrome://global/content/bindings/autocomplete.xml
Line: 813
Probably a regression from bug 414845
Blocks: 414845
Indeed, the popup code can't assume that mInput is anything other than an nsIAutocompleteInput. In the content autocomplete case, for example, it's a nsFormFillController instead of an actual element.
FrnchFrgg, any idea how to fix this? Maybe try/catch would be acceptable in this case? If nothing else, backing out bug 414845 would do.
Assignee: nobody → frnchfrgg-mozbugs
gavin said on irc that try/catch would be a crude hack. Perhaps adding a "if (popupishistorypopup)" at the right place, or add a specific event listener for the urlbar (or for autocomplete[history=true]) ?
Flags: blocking1.9?
Backed out bug 414845, so this should be fixed now.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Duplicate of this bug: 416024
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.