download causes continual stat calls

VERIFIED FIXED in M18

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: colin, Assigned: neeti)

Tracking

({embed, perf})

Trunk
x86
Linux
embed, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

19 years ago
I'm seeing this in the 0602 M16 build on OpenVMS (cos that's where my debug 
environment is), but I suspect is happening on all UNIX based builds.

Downloading a large file over a reasonably fast link is very slow. One of the 
reasons I've been able to determine so far is that it appears that each file in 
the disk cache is continually getting stat'd while the download is in progress. 
I have no idea why, but I can see this quite clearly when I put a trace on the 
stat routine.

If I disable the disk cache (set size to zero) the stat's stop and the download 
speeds up.
over to Networking (i don't think this is an xp apps bug, but lemme know if
otherwise).
Assignee: don → gagan
Component: XP Apps → Networking
QA Contact: sairuh → tever

Comment 2

19 years ago
hmmm.... this would be a bad thing! 
Assignee: gagan → neeti

Updated

19 years ago
Keywords: nsbeta3
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Updated

19 years ago
Keywords: embed, perf
Whiteboard: [nsbeta3+]

Comment 3

19 years ago
how are you downloading the file?  
(Reporter)

Comment 4

19 years ago
I'm not at my VMS system right now. I'll re-test with my M17 build later this 
morning to see if its still happening, and if so, post exact details.
(Reporter)

Comment 5

19 years ago
I am not able to reproduce this with my M17 build, so I guess whatever
the problem was, got fixed.

Feel free to close this bug report. Should I ever see the problem again,
I'll reopen it.
(Assignee)

Comment 6

19 years ago
Closing this bug as per reporter's comments
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
verified:
Linux rh6.0 2000090708
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.